Allow Mic access on Mac OS

I am struggling to find how I can give WfView access to my laptop Mic.
I have downloaded the latest build on my M1 macbook and everything appears to be working fine except when I press TX no audio?
I am sure the issue is because I haven’t allowed the program access to the mic in security & privacy, but I cant find a way to add it?

Any help appreciated


I have the same audio issue Paul.
Good thought about the MacOS needing to grant privacy rights to the app to access the mic.
However M0VSE seems to have it working on his Mac.
Are you Big Sur or Catalina or ?

Jonathan G0DVJ

Hi Jonathan

Its on BigSur


Hi both,

Yes the TX audio on Mac is certainly a puzzler, Jonathan I haven’t had a chance to go through the log you sent me as I am at work at the moment. Hopefully have a solution soon!

73 Phil M0VSE

I’ve got the same issue, no TX audio. I’m on Mojave 10.14.6 and using the latest build.
73 Frank

I think that I know what the problem is. It appears to be a known issue where Qt apps fail to request microphone access, however when they are executed within QT Creator (which is how I usually run wfview) the request is made successfully.

I suspect that it will require that the app is properly signed which is something that I haven’t been doing up until now. I will try to get a signed binary created and see if that improves things.

73 Phil M0VSE

I can reproduce the problem by running wfview outside QT Creator so hopefully I will have a solution for this soon!

Look forward to trying it Phil.
Thanks for quick response


Thanks Phil !

When I enable the virtual com port (softlink to /dev/ttys000) on Mac, wfview “hangs” when tuning (have to use ForceQuit to exit the program). Could this be the same issue: Inside QT Creator vs. Standalone?

73 Frank

That’s possible Frank, I have a bit of a workaround that seems to work for me. If you use Terminal and run the actual executable, it seems to bypass the security check.

cd <location of>

That then successfully accesses the microphone for me (running the app from Finder doesn’t)
Frank, can you see if the pty access also works using this method?

73 Phil M0VSE

Well, the workaround works for the no-tx-audio issue, now microphone works, nice :slight_smile:
But not for the virtual serial port problem. I cloned and build the latest version with QT creator, but no change.
73 Frank

Hi Frank,

What device name are you specifying for the pseudo-term?

de W6EL

Hi Elliott,
I took the first one from the drop down list: /Users/frank/rig-pty1.

73 Frank

Hi Frank,

Looks sane… just making sure you didn’t define something out of bounds.

de W6EL

OK, I have been fighting with this all evening. I think that the latest MacOS binary (dated 2021-05-16) should now correctly request Microphone access.

It is all related to how MacOS apps are required to operate in a sandbox and specifically request access to files/devices outside of this.

One downside is that the log file and pty file are now created in the current users Downloads directory (as this is one of the few directories that a sandboxed app can request access to). You will also notice that the configuration will be reset once you run this version as the app identifier is now set to the correct value (org.wfview.wfview).

This is a process that we will eventually have to go through if we want to be able to distribute wfview on the Apple app store anyway so hopefully we can sort these issues now.

73 Phil M0VSE

1 Like

Hi Phil,

Just tried the new build this morning with the IC-9700:

  • Microphone (TX-audio) works fine.
  • No hang with virtual serial port configured.
  • Integration with WSJT-X using Blackhole as Virtual Audio Cable:
    — CAT control works, but WSJT-X gets confused when changing freq. on the 9700 (due to Transceive Mode?) but this is not a practical concern.
    — Receive audio works fine.
    — Transmit audio (tune in WSJT-X) works intermittently and breaks up.

The last point however could well be related to the limited CPU power of my laptop. (MBP Late 2012…) WFview is taking up a lot of CPU cycles :slight_smile:

73 Frank

That’s great Frank, looks like we are on the right track!

I am planning to try to move the audio handling away from QtMultimedia to either Portaudio or rtaudio libraries as they are better suited to realtime audio, and I have noticed that MacOS audio support in Qt may not be as stable as it could be.

73 Phil M0VSE

Hi Phil

Yip that now works, thanks.
One thing I did have an issue with was when I first tried it, pressing TX did nothing and the program appeared to crash, unresponsive and spinning wheel. I force quit a few times and retried it, I had to reboot the rig to get the WiFi connection back. I eventually discovered that it was down to me still having the security and privacy window open and unlocked. Soon as I locked the privacy settings it all worked.
What was the location of the log and pty file previously so I can tidy up?
Next I will try getting it to work with WSJT-X

Thanks again

Hi Paul.

The pty should have been deleted when the program was closed but if not, it will be in the current users Home directory. The log file was stored in the default temporary directory for the user: $TMPDIR/wfview.log

73 Phil


Thanks Phil, no sign of either so it did cleanup after itself.