Audio (pings) when using server

I’m new to this forum but I’m following the discussions for quite some time already and also managed to set up part of what I want to use wfview for.
Everything works fine but receiving audio. I did not try any tx yet. I went through some of the articles and tried changing some settings but to no avail.

  • Here’s my setup: Wfview: 1.61, Radio: 7851
  • A Pi4 is connected to the radio via 1G network as server
  • A laptop running W11 connects to the Pi4 via Wifi through the router. All GUI things are working fine and without delay. Unfortunately audio does not get through but only like some pings. I would not even call it distorted because you cannot “decode” anything when listening to it, be it CW (main mode) or phone.

RX Codec on the Pi4 was set to Opus 1ch but upon connecting to the radio, a message at the bottom appears: “Opus codec not supported, forcing LPCM16”. So I set it to LPCM 1ch 16bit
Audio System is set to Qt Audio, switching to PortAudio does not change anything

RX Codec on W11 is set to Opus 1ch

When connecting directly (wifi-router-radio) to the radio from the laptop, all is fine. Unfortunately, I wasn’t able yet to test connect from outside my home (using Wireguard). All testing is done in-house.

Basically, I think I would not need the server instance if I manage to connect to the radio using the VPN tunnel. As a matter of fact, I only set-up the VPN yesterday.

Any suggestions what else I could try?

BTW, I’m very much looking forward to the version that enables the use of an external key.

73 Norby

Hi Norby, are you aiming for remote work to this QTH?
If so I guess that’s why you are testing with the VPN, else its not required?
Maybe you have the possibility to connect your router to a VPN network as Tailscale or Zerotier and connect directly to your 7851? That seems easier to me (if possbile in your case).

73, /Tomas

unless you have a good reason to use a pi, just use the internal server of the 7851.
(and let me know what that reason is)

Hi, I think I got it working now. I switched from LPCM 1ch 16bit to 8bit and that setting works fine while testing in-house through the VPN.

@Tomas: Yes, the plan is to be able to work my station from abroad.
@Roeland: There are 2 other radios (7300/9700) that I want to access as well.

ok in that case:

  • use the PI ONLY for the 7300
  • Use the direct connections/internal server on the 7851/9700
    use three sets of UDP ports.

I also have for every rig a separate wfview config which makes running them all at the same time
juct by clicking the right icon on my linux desktop.

1 Like

@ham Hi just to give you a refference.

I have IC-7610 with LAN in remote location accessible over LTE link and Wireguard VPN.

With direct connection to LAN it works good enough to make daily QSOs with audio modulations.

My settings on wfview (client side) are:

audio latency: 250ms both TX and RX
codec: LPCM 1ch 8bit both TX and RX
Sample rate 8000

RX latency shown by wfview is around 150 ms with rtt ~50ms

and it works without issues.

I also had there for test IC-9700 and IC-705 and all works the same when with LAN.

With RPI I am havving some issues right now - but most probably its due to my old RPI with weak performance…

1 Like

basically, unless you have VERY specific technical reasons, use the LAN port. It’s basically an inmense downgrade if you would use the USB cable for this.

(And Yes Dawid… you have some other reasons)


You might want to consider just connecting to the 7851 directly, over Ethernet. wfview works very well with this radio. You do not need to run your own server. The radio has one built in. Just open wfview on your computer and supply the IP address, username, and password for your IC-7851.

de W6EL

Finally had the chance to remote access from work and it worked fine with the LPCM 1ch 16bit setting while connecting directly to the Icom.
Wireguard works ok on Windows but doesn’t on Linux. Need to further try and error.
Next step is to include both IC-7300 and IC-9700.

TU for the support.

73 Norby

(applies to any linux).

@ham interesting thing about Wireguard - I have never used it on Windows, all my computers are Linux… :wink: and all have wireguard;)