Changing antenna not working

Hello all,
I’m using wfview 1.1 with my R8600. I have 3 antennas connected to the radio. I have noticed that changing the antenna in wfview does not change the antenna on the radio. Is that a known issue ? i am not sure if it is suppose to work at this point.

Many thanks

some parts of the code are based on othe rrigs so possibly the R8600 implementation has an issue with that. We’ll look at it.

Hi Sylvain,

Did you ever try it with earlier versions? Just making sure we didn’t break anything. I thought this feature worked but I will have to take a look at it.

de W6EL

I’m pretty sure it used to work. I will remove my current version and install the one i had before and test it again.

Ok here is what i did:

1- Confirmed again that in wfview 1.1 changing antenna in the software does not change the antenna on the radio

2- Uninstalled wfview 1.1
3- Installed wfview 1 and confirmed that changing antenna in the software does change the antenna on the radio.
4- Uninstalled wfview 1
5- reinstalled wfview 1.1 and confirmed again that changing the antenna in the software does not change the antenna on the radio

Hope it helps

Hi Sylvain.

Looking through the code for antenna selection, I suspect that this has never worked? Other rigs with multiple antenna ports also have a dedicated receive antenna (IC7610 and IC785x) and the command that we send to the rig is geared towards this.

I have just looked at the CI-V reference for the ICR8600 and the antenna select command is a single byte (unlike the 2 byte command that we are sending) this is an easy fix and I will make sure that it is in the next 1.2 beta!

73 Phil M0VSE

Hello Phil, i confirmed that it worked in version 1

That’s interesting, as prior to the RX antenna option that was added in v1.1, wfview was sending what should still be an invalid command for your radio! In v1.0 it sent two bytes, with the second byte always being 0x0. Since 1.1, the second byte should also be 0x0 if you don’t have an RX antenna. Your radio is expecting a single byte though so the behaviour is likely to be ‘undefined’.

73 Phil M0VSE

I really don’t know what to say as i am not a programmer. All i can say is that it works with version 1 and does not work with version 1.1.

to the master branch we’ve pushed a fix that should work for you and shudl not break the 7610/785x antenna selections (as in: no changes to it).

the antenna selection matrix is another “interesting” feature that needs some TLC at some point.

Thanks, how do i install this fix ?

either build the s/w yorself or wait until v1.20 is released – think we’re - apart from one thing hard to fix - there soon. I’ll discuss and see.