Clicks & pops on audio (IC-705)

I know this has been mentioned before

[Choppy audio on MacOS - wfview](

…but I have been doing a series of experiments with my IC-705 to see if I can narrow this down. In most cases my settings are LPCM 1 Ch 16 bit, 2400 sample rate, 300 ms latency - but I have also tried variations to see if I can get any improvements. All on release V1.1 downloaded today.

On the IC-705 I have set USB AF Output Level to 40%. The WLAN AF Output no longer seems to be adjustable in firmware V1.26.

Single client tests:

Pi via USB - works fine; audio is not routed
Pi via LAN - choppy/clicky audio
Mac via LAN - fast “tick-tick” on audio plus crackles
Mac via USB - works fine; audio is not routed
Win10 via LAN - very good

Client/server tests:

Server: Mac via USB. Client: Pi - couldn’t get any audio at all
Server: Mac via LAN. Client: Pi - some crackling
Server: Mac via LAN. Client: Win10 - some crackling
Server: Pi via USB. Client: Mac - rapid clicks
Server: Pi via USB. Client: Win10 - perfect! Seems to be the best combination.
Server: Pi via LAN. Client: Win10 - slight crackling, and waterfall is not running

I could do some other combinations, and I also have a Macbook so I could do Mac-Mac tests, but I think that is enough for now. Also I haven’t tested transmit audio yet.

Any thoughts or comments?

I’ve had a lot of issues with version 1.1 and also with 1.2c
I think it’s best to put the latest beta (1.2d audio-enhance)
In Pi you can easily compile it by downloading the script

and editing which branch you want to compile.
I don’t know if they will have moved the UDP server modifications to the master, but they greatly improve remote performance.
Also, you can use OPUS instead of LPCM, which I think gives better audio performance.

Thanks - I will give that a try.

It might be a few days before I do so, as I’m expecting delivery of a new HF linear today :wink:

1.2d audio-enhance – that’s in master already.

Using the fullbuild script, the 1.2c audio-enhance version seems much better; many thanks!

How do I point the script to 1.2d?

Hi Russell, I’m experiencing same clicking audio, and what I found today was that if I use a bluetooth headset for audio out ONLY, audio is good!
BUT… if you turn on bluetooth mic (at least for me) I get no audio at all.

I’d be interested if this cleans up your audio too.

  1. VE7BNR - Gordon

One thing that has occurred to me, the clicks&pops could be due to a sample rate mismatch?

Internally, wfview always works at 48KHz. If your device is setup for 44.1KHz then you may get audio issues (other platforms handle this conversion automatically, I’m not sure about MacOS).

It may be worth checking what sample rate you have configured for each device within Applications/Utilities/Audio MIDI Setup. It wants to be 2 channel, 48K, 16bit (as that is what wfview expects). Some devices will only support 32bit float but I don’t think that’s a problem.

73 Phil M0VSE

Now ur talking… I use one mic that outputs at 192KHz. The BlueTooth headset manufacturer doesn’t provide a sample rate but 96KHz appears to work best on the ANAN7000.


Yup, that is it! Damn sample rate on built in output. set it to 48kHz and audio is great now!
Now to figure out why Bluetooth mic causes no audio.

That’s really interesting. What was the default sample rate?

wfview has an internal sample rate converter and ‘requests’ 48K from the operating system but if this is rejected, it can (in theory) convert between any rates. Looking at the code, it only expects the sample rate to be 44.1K or 48K though. I should be able to make this work with any rate as long as it can detect what the ‘preferred’ rate is. I know that newer Macs use 96/192K but sadly my Late 2013 MBP doesn’t :slight_smile:

73 Phil M0VSE

On my iMac, the default seems to be 44.1 kHz. I have changed this to 48 kHz in Audio Midi Setup (strange that it is hidden there rather than in the System Preferences audio setup).

On the Pi, I have edited /etc/pulse/daemon.conf to “default-sample-rate = 48000”. No idea whether this makes a difference, but it doesn’t seem to do any harm!

I haven’t tried Windows yet, but so far so good and I’m getting clean audio now.

Hi Russell.

I am pretty sure that is only required on MacOS. Wfview will specifically request 48K but I can add some more error handling if this fails. It is in areas like this that developing for multiple platforms can be quite a challenge, as they don’t always work in the same way.

73 Phil M0VSE

Hi Phil,
the audio samp rate was the problem here. On my MacPro5,1 with Monterey (OCLP 0.3.1.) I had to set audio samp rate to 48000 Hz to get good audio with wfview. Thanks!

73, Norbert

I have choppy/clicking audio when using the on-board sound card of the Mac.

I took a USB headset, plugged it into my mac, and the audio was fine.
The audio is only choppy with the on-board sound card.

Now, it will break up if the computer is under load some, such as opening chrome, things like that, but if you minimize usage of the computer, it seems to run fine.