Help configuring audio via wireless connection

I’m running wfview 1.0 under Ubuntu Linux 20.04LTS connected to an IC-705 via a wireless connection. I’m following the instructions in the Audio Configuration section of the User’s Manual and have the loopback audio devices created correctly (I think). I see them in both WSJT-X and Fldigi.

However, how do I set the levels? In WSJT-X and Fldigi, the applications connect to PulseAudio streams and I can adjust the levels in pauvcontrol. But I see neither application in pauvcontrol and I don’t see the loopback devices there either in any stream or as an input or output device.

So…how do I set the levels? How do I get the loopback devices showing up in pauvcontrol mapped to an application? Or is there something else I ought to be doing?

Harry Bloomberg W3YJ

Hi Harry,

Try the “LAN” slider. This will adjust the LAN audio level going in to the radio. For the receive audio, the “AF” slider should work.

Let me know if it works,

de W6EL

1 Like

Adjusting both sliders in wfview had no effect.

When I exit and the restart WSJT-X, I receive the following pop-up error:

Error in Sound Input
Request input audio format is not supported on device.

I went through the audio device selection again in WSJT-X and it appears to me as specified in the User’s Manual.

Harry W3YJ

I find Linux audio to be hopeless confusing…

In WSJT-X, I changed the input device to plughw:CARD=Loopback,DEV=1. Much to my surprise I see FT8 signals in the WSJT-X waterfall, and the wfview AF slider controls their level.

At the moment I don’t have a xmit antenna available, but I will speculate that selecting plughw:CARD=Loopback_1,DEV=1 might be a good choice for WSFT-X output.

So…what is going on here? Is this a usable solution? Does the documentation need to be updated? (Yes, I used to work in Software QA for many miserable years.)

Harry Bloomberg W3YJ

Hi Harry,

I too find linux audio frustrating. When it works, it’s great, but when you’re configuring things, it sure is confusing. Some of this is simply the “price for allowing everything to be endlessly configurable”, but some is also simply because of linux’s mixed heritage and only recently becoming a somewhat popular desktop option. Regardless, I accept it because there’s definitely things I like about it!

I think you have a usable solution. Please document your steps carefully so that if you reboot and have to re-do some of it, you’ll know what’s involved. And if you want to send us a detailed how-to, we may be able to incorporate that into our wfview documentation.

Thanks, and keep at it!

de W6EL

I went up on my deck with the mag loop and got on the air. In WSJT-X I changed the input devices from hw: to plughw: and it all worked.

The naming convention is different in Fldigi. I found by trial-and-error that these devices worked in PortAudio. Wish I really knew why they worked.
Capture: Loopback: PCM (hw:10,1)
Playback: Loopback PCM (hw:11,1)

Please don’t publish this in a formal document yet because 1) I did this in a hurry to avoid the rain 2) I want to try this out on a Raspberry Pi and 3) I’m leery of results arrived at by trial-and-error.

Harry Bloomberg W3YJ

Verified selection of soundcards in WSJT-X and Fldigi is the same on a Raspberry Pi 4 running Buster. But…

Configuring was difficult. in /etc/modprobe.d/virtual-sound.conf I had to change

options snd-aloop enable-1,1 index=10,11


options snd-aloop enable=1,1 index=0,1

Using the indices of 10 and 11, I had the following error in cd cd /var/log:
cannot find the log for index 10 (range 0-1), error: -19
I also had a similar error for index 11.

I tried changing the indices to 100 and 101, and that caused errors also. So I settled on indices of 0 and 1. It works but I’m not sure why. In Fldigi my Capture device is now Loopback: PCM (hw:0,1) and the Playback device is Loopback: PCM (hw:1,1).

I have limited hardware, so I don’t know if this is a generic problem with the Raspberry Pi configuration or specific to my Pi.

So, I did a lot of operating with Ubuntu Linux and all worked well! I’ve not yet tried my Raspberry Pi on the air but it ought to work. But with an 800x480 display wfview is way too large, so I’m not likely to use it much.

Operated with Raspberry Pi on the air. Works well! But wfview is too large for 800x480 display, will use wfview on this Raspberry Pi only for testing purposes.

Hi Harry,

Glad to hear it’s working. When I re-visit window resizing, I’ll see if there is a way to support lower resolutions. It’ll be difficult with the number of features sneaking in to the main window, but we’ll see what we can do.

de W6EL

I have nearly have WSJT-X working with WFview on Raspberry Pi 400 to connect over wireless to IC-705. Got stuck at the step of selecting the appropriate loopback ports. I see only two in the WFview audio combo box that match the format described in the documentation: hw:CARD=Loopback, Dev=0 and hw:CARD=Loopback, Dev=1. In particular no hw:CARD=Loopback_1, Dev=.

Could this be a result of a different automatic naming convention in this version of Raspberry OS? What parts of the port names are important in this context? Or maybe this Pi doesn’t have enough hardware to support two of these things?

Thanks for advice.


Did you follow the instructions in Audio Configuration | wfview

That describes how to create both Loopback and Loopback_1 entries You need both as Loopback Dev=0 should be used for wfview audio output and Loopback_1 Dev=0 for input. You then use Loopback Dev=1 for audio input in wsjt-x and Loopback_1 Dev=1 for output.

The important line is in /etc/modprobe.d/virtual-sound.conf:

options snd-aloop enable=1,1 index=10,11

The index=10,11 tells it to create two loopbacks, you likely only have index=10?

73 Phil M0VSE

This is my exact experience with wsjtx and fldigi. But I’ve still got something wrong because I have no “monitor” output. That is, my speakers are dead quiet. I’ve had a couple successful, albeit quiet, QSOs in each app. Any clues on getting some speaker output?

Thanks: …DonA

Hi Don.

It isn’t (currently) possible to get a monitor output from within wfview if routing audio to/from a loopback/virtual sound card, this is something that we could potentially add though.

In Windows, there is an option within the Sound control panel where you can enable ‘Listen to this device’ which would allow you to hear the virtual sound card audio through the default audio device. I’m sure something similar is possible in Linux but wouldn’t know how to do it?

73 Phil M0VSE

Thanks Phil.

I’ll stay tuned for a possible “Monitor Audio” feature. Meanwhile I’ll live with silent FT8 and RTTY QSOs with loopback audio, but switch wfview to the “default” audio output for monitoring CW.