Installation on Ubuntu 21.04

for testing I spin up a live image that I then install in a vm.

I actually shuld start kicking the package maintainer because that’s where the issue is.

I haven’t figured out how to change the path, I still haven’t been able to install it.

use locate or find to find the library name/path and use that one.

You might want to try compiling from source, it’s not as bad as it may sound. The INSTALL.md file contains the directions, which work just fine in Ubuntu, Debian, and Mint.

–E
de W6EL

On Linux Mint 20.1 on amd64:

sudo apt install libqcustomplot2.0 libqt5multimedia5 libqt5serialport5

But the symbolic link will be (one line):

sudo ln -s /lib/x86_64-linux-gnu/libqcustomplot.so.2.0.1 /lib/x86_64-linux-gnu/libqcustomplot.so.2

On Win7 and USB to 7300, wfview works beatifully so far. Now I will test remote from Linux → LAN → Win7 → USB → IC7300.
Thanks guys!
73 de SA7CND

we know that debian based systems make a mess of these kind of things. We hope that at some point the maintainer will fix the omission. In the mean time I’ll add it to the instructions.

True, in fact I wanted to ask if it is possible to post a detailed guide for installing on a linux system.

1 Like

Antonio,

INSTALL_PREBUILT_BINARY.md (in the prebuilt package file) tells what to do to
install wfview. Generally they consist of two to three packages to install, sometimes
create a link and fire off wfview.

Can you point out where we need to change the instructions to a more detailed one?

R.

when I type this line it tells me it can’t find it and I can’t figure out where to find it

sudo ln -s /lib/x86_64-linux-gnu/libqcustomplot.so.2.0.1 /lib/x86_64-linux-gnu/libqcustomplot.so.2

hi,

it is worthwhile to note that

contains the latest published version. you might notice that the release version contains instructions for older mint/ubuntu versions.

r.

Oh, and I needed the sudo apt install libqt5multimedia5-plugins as well to get audio running on the live-stick…

Antonio,

I installed Ubuntu 20.04.2 as a live system on a stick

I then unpacked the .tar file that created the directory /dist.

I then tried to install the 3 mentioned library files. That fails due to
Ubuntu not having the universe and multiverse repositories available.

Why Ubuntu considers this “not necessary” I don’t know but probably to
avoid inexperienced users to run into troubles…

Ubuntu by the way does even not tell that the OS is in fact Linux any
more… That’s one reason I switched to Linux-Mint some years ago…

So on a fresh install you need to add these repositories by executing
these lines in a terminal:

sudo add-apt-repository universe
sudo add-apt-repository multiverse
sudo apt update

After having done that the 3 libraries install with all the dependencies
without a problem.

From the /dist directory I ran the command sudo ./install.sh
No error was reported, just “Done!”.

Then I copied the second line given in the INSTALL_PREBUILT_BINARY.md
textfile under ###Ubuntu

sudo ln -s /usr/lib/x86_64-linux-gnu/libqcustomplot.so.2.0.1
/usr/lib/x86_64-linux-gnu/libqcustomplot.so.2

It executed without an error

And then the wfview command given on the /dist~$ prompt gave me a
running wfview. In “Show Applications” the blue W showed as well and a
double click started the program.

Now if I can do that from a live stick you should be able to do so as
well…

But it still leaves me with the questions: Are you using a fresh install
of Ubuntu of did you alter all sorts of things prior to running this
install like upgrading from previous ubuntu versions or experiment with
other software not made for debian/ubuntu that messed up your current
distro?

73,
Peter - PA0PJE

Sorry the system won’t let me answer your questions, I am new here and rights to send only one answer to you. So I try it this way, as suggested…

Hi Antonio,
On my RPi4 I used the “fullbuild-wfview.sh” script so that was an install from source. However, I use a 32bit “Raspbian” OS there. I downloaded the “fullbuild-wfview.sh” and ran it after making it executable with the given “chmod +x” command, I then tried the prebuilt binary install as well and both work. I first tried to use a Bluetooth speaker which did not work and then I used audio via my HDMI monitor to that speaker. Everything works OK via LAN, I did not yet try a USB-cable.
I have tried 64 bit Ubuntu Mate but that crashed all the time both on my Pi as on my desktop PC so I use 64 bit Mint/Mate on my desktop PC and 32 bit Raspbian on the Pi.
Hop this will help a bit.
Good luck,
Peter - PA0PJE

One more thing: My RPi just crashed running wfview due to overheating…!

Hi Antonio,
I have downloaded Ubuntu Mate 20.04.2 for RPi4 (64bit). I will install it, see if this one remains working and install wfview. I let you know what my findings are.
73, Peter - PA0PJE

Hi Peter i use Ubuntu Mate 20.04.2 for Raspberry Pi4 64 bit and following your procedure always gives me the same error

Hi Peter, finally with the script I was able to successfully install wfview on my raspberry Pi4 on Raspbian.
Everything works perfectly!
Thank you