Installation under Mint21 fails

Hello everyone,

for me the installation under Linux Mint 21 fails.
I get the following error message:

In file included from …/wfview/audiohandler.h:32,
from …/wfview/udphandler.h:27,
from …/wfview/rigcommander.h:11,
from …/wfview/wfmain.h:24,
from …/wfview/main.cpp:14:
…/wfview/audioconverter.h:17:10: fatal error: eigen3/Eigen/Eigen: Datei oder Verzeichnis nicht gefunden
17 | #include <eigen3/Eigen/Eigen>
| ^~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [Makefile:961: main.o] Fehler 1
make: *** Auf noch nicht beendete Prozesse wird gewartet …
Error in make step.
wfview was not compiled.

does anyone know this problem
is there a solution ?

Many thanks in advance
73 de Jochen DC6RJ

in it’s stated that you need to install libeigen3-dev


I highly recommend just using the build script, which should install libeigth3-dev for you:

Let me know if you ran the build script and still get this error.

de W6EL

Hello Jochen,

the information from Elliott is important!
I reinstalled Linux Mint 21 a few days ago and wfview works great whether it’s via usb or wifi.
See also Thread “WFview Server” from April 1 and my post from 30. April 2022…

73 de Andy DL9MDV

1 Like

Hi Elliott,

I have used the build script on my laptop,
in doing so I received the error message.
after i installed by hand the following files:

sudo apt-get -y install libeigen3-dev
sudo apt-get -y install libportaudio2 libportaudiocpp0
sudo apt-get -y install portaudio19-dev
sudo apt-get -y install librtaudio-dev librtaudio6

the script ran without problems and wfview was installed.

73 de Jochen DC6RJ

Hi Jochen,

I’m glad it is working! If you can share the errors that would be helpful; I do not have a computer with Mint 21 and I’m guessing some of the packages have slightly different names. My main machine is Mint 20.

Let us know how it goes, very interested in your feedback,

de W6EL

Hi Elliott,

what shut i send ?

73 de Jochen DC6RJ

Ideally send the text of errors when you ran the build script on Mint 21. Or any details you can recall that may have caused it to not work.

And… now that it works, let us know any other problems.


de W6EL

Hello Elliott,

as I wrote above, I had to install the following files manually:

libeigen3-dev, libportaudio2, libportaudiocpp0,
portaudio19-dev, librtaudio-dev and librtaudio6

meanwhile installed wfview on my desktop, where the script ran without any problems.

my desktop is also linux mint 21,all updates for mint 21 were carried out before the installation of wfview, unfortunately i can’t submit any error messages for the installation on my laptop because i deleted everything when closing the command prompt.
but since the installation worked perfectly on my desktop, I assume that there was a problem with my laptop and not a general problem with the installation of wfview.


the question was not what you had installed but:

“Ideally send the text of errors when you ran the build script on Mint 21. Or any details you can recall that may have caused it to not work.”

because that’s the only way we can find out why the script didn’t work for you. Even if your setup was in a sick mood there :wink:

So, next time you build with the script, could you uninstall the manually added files and output again?