Intermittent / oscillating audio on Ubuntu 20.04

I’m running wfview on Ubuntu 20.04.4 and i’m getting intermittent audio. It’s best described as oscillating, choppy or fluttering, where it is on and off several times a second.

So far i’ve tried:

  • connecting the Ubuntu laptop and 705 to my Wi-Fi router: problem exists
  • connecting the Ubuntu laptop directly to the 705 access point: problem exists
  • wfview on a Mac via my Wi-Fi router: works without issue

By deduction the 705 and wireless config is fine and the laptop is a high spec, 2021 purchase running a fresh install on Ubuntu. Hardware utilisation is negligible. So i think it is something Ubuntu specific.

I do have to run wfview153 to avoid the segmentation fault, if that’s relevant.

Any ideas?

Thanks

Hi Kevin.

Can you post the first line from your /tmp/wfview.log file please as that contains various info regarding your environment?

I have not been able to reproduce this particular issue but I know a couple of other users (including Elliott) are experiencing this pulsing audio it can usually be (temporarily) cleared by moving the RX latency slider (which causes audio to be restarted.)

I am hoping to replicate the environment of a user with this issue so that I can try to find what is causing it. I suspect it may be a bug in earlier versions of Qt (which wfview relies heavily on).

73 Phil M0VSE

It’s also worth checking that you are on the latest version, there have been a few updates to master over the last couple of days which could impact this issue.

73 Phil M0VSE

Hi Phil

Top of log here:

2022-05-07 10:26:44.450 INF system: “Starting wfview: build ea09647 on Jul 26 2021 at 12:05:58 by roeland@snowpa.invalid”
2022-05-07 10:26:44.450 INF system: “Operating System: Ubuntu 20.04.4 LTS (x86_64)”
2022-05-07 10:26:44.450 INF system: “Build Qt Version 5.12.7. Current Qt Version: 5.12.8”

I also tried increasing the RX latency, which had an effect. The real-time latency was up to 25ms but the slider needed to be set to 200ms to remove the flutter completely. Is this a credible workaround?

Trying the latest version now

73
Kevin M0AHN