No receive audio

I knew I should have left well enough alone…

I tried using portaudio, didn’t work, so I compiled/installed wfview again without it and now I no longer have rx audio. I do actually get it in wfview on the client, but it seems like the sound is not being passed on to JTDX. I am able to transmit and rig control works fine. JTDX, wfview and VAC have all been reinstalled on the client and audio settings checked/reset about 100 times. Tried everything I can think of at this point. Any ideas?

So, it turns out a server reboot fixed the issue. I don’t really understand why because the wfview client could rx/tx just fine and I was thinking there was some issue with VAC.

However, while I could now receive and decode signals in JTDX (no apparent change in Wfview), when I started to transmit, my signal was a couple of kHz wide…rebooted the Wfview server again and now everything seems ok. Don’t really understand why rebooting the server fixed both issues, but I don’t think I’m going to touch anything for a while.



last week we had issues where some account could not log in to a linux server; everybody could except that one account. Trboubleshooting, looking at logs, differences. No way I could find a reason.
Restarted (RHEL7) and all was working just fine … go figure :wink:

happy it’s working again.

similar problem here:
Server: Raspi with raspian os
Client: W11 Pro
Application: wsjt-x 2.4.0 via VAC 4

Audio looks like this:

What I tried:
Client pc changed to an other computer no change.
Wfview at client side is receiving ok, output of receiving audio is possible to redirect to speaker => OK
Wfview at client side redirected to VAC only attached signal is received, Yellow color refects the trial voice. Why this pattern shows up I don’t know. Maybe digital background noise from HW. There is no audio signal from server side.
Transmitting is working correct when pushing the tune button on wsjt-x and the trial voice is also transfered to Transceiver.

Rebooted server, client and all apps several times no change.
Changed the protocol of wfview client to all available without any change.

Could it be a problem of raspbian os?
Has anyone running it at raspi as server with raspbian os succesfully?
If I can redirect audio to speaker, why it doesn’t go into the VAC pipe and to wsjt-x?

Any hint is welcome, I’m at the end of my knöwledge.

73, Michael

Hi Michael.

Yes most of the server development is done using exactly that setup so it should definitely work.

If audio is working OK on your Windows 10 client when routing to mic/speakers and not VAC then the server isn’t likely to be the cause of your problems.

Are you using a different virtual audio cable for TX and RX audio? you mustn’t use the same one as this will likely create a feedback loop. You will need to create a second VAC pair in the VAC control panel.

73 Phil M0VSE

Hello Phil,
thank you for your reply. Now I rechecked and I was wrong, because even when redirecting to speaker I get only the trial voice nothing else. (earlier I got the signal because via the microphone used…)

I use anydesk on all my systems and even disabling changed nothing.For control I changed the wfview port from 50001 to 50004.

Could it be just a port problem at my windows client?




Hi Michael.

What audio devices have you configured in wfview on the server machine as that must point to the USB codec audio devices for your IC7300?

73 Phil M0VSE

Hello Phil,
have you seen the film “The Name of the Rose”, after the book from Umberto Eco?
Then you will remember the poor guy the tortoured later and he alwas was clapping with his hands to his head and was shouting “Stupido Stupido”; it could have been me. :slight_smile:
You asked the right question and I have overlooked the wrong entry there all the time.
For input and output I selected the output driver.
Thank you for your hint.
73 Michael