No waterfall IC705+wfviewv1.1

New user. I am trying to use wfview v1.1 on my IC705 firmware v1.26. I have it installed on my RPi 4B 8GB (both full HDMI and headless) and on a Dell Inspiron 7700 (32GB ram) running Win 11.
I get audio just fine and CIV but no waterfall or signal level readings on either. I have tried both AP mode and through my WLAN with the same results.
Everything seems to be working nicely except that there is no waterfall or signal level. The '705 is displaying as normal.
What setting am I missing? I’m betting that it’s obvious to everyone but me!
Don, ND6T

Hi Don,

Do you have CI-V Transceive enabled? You’ll need that enabled on the radio. Do you see “IC-705” or “NONE” in the bottom-right corner of wfview?

de W6EL

Hi Elliot!

Indeed, I do have it enabled. Not the echo, though. That didn’t seem to help. No, it doesn’t identify the radio (I couldn’t find a field to instate that), it just shows “NONE”. I do have the waterfall enabled but it makes no difference.

The CI-V works as far as control, feedback from the radio (it changes on the computer as I physically turn the dial), and the audio works. Both platforms (Raspberry Pi and Win 11). It does so on AP (Access Point) and through the on-channel WiFi LAN, again on both platforms.

Could it be that the recent updates to the IC-705 firmware changed the calls? Attached is the notification for v1.20 although I am running v1,26.

Don’t you hate it when they change firmware or libraries?! They tend to update you right out of business. Or…Is this some silly error on my behalf?

Thanks for the prompt reply!

73, Don

(Attachment IC-705_ENG_Info_V120_0a.pdf is missing)

Hi Don,

I think wfview should work with any of the known firmware versions, but I’ll let Roeland or Phil reply since they each have an IC-705.

“NONE” means the radio did not answer our Rig ID query, and thus, what you’re seeing in wfview is a sort of “safe default” mode without a lot of the features connected correctly.

de W6EL

Hi Don,

I am running the latest version of the IC-705 firmware and it works fine. As Elliott says, your rig isn’t being detected properly which usually suggests a problem with CI-V transceive?

It is worth double-checking the CI-V Transceive is in fact enabled in the rig as various other software (Omnirig) will disable it. Also make sure that you leave auto CI-V address detection enabled in wfview (don’t check Manual radio CI-V address). Once verified, it is also worth restarting wfview.

73 Phil


AHA! That was it! I had manually selected it.

Works like a charm! Incredible programming. Slick!

Thanks everyone. I truly appreciate the help.




Yes manual selection is a workaround if you can’t use CI-V transceive mode to detect the address. The problem is that also disables a large part of the rig detection logic!

73 Phil