Pardon the off topic post here, but I figure the WFView developers might have a clue on this.

I’m not using WFView, but I am trying to talk to an IC-7610 over a LAN (although using USB).

I have the 7610 connected via USB to a Raspberry Pi 4B. I’m trying to use the linux ser2net daemon on the Pi to relay data from the USB port to a TCP connection over the LAN.

To test the setup, instead of ser2net, I used a serial terminal program on the Pi to connect directly to the USB port of the 7610 (in my case /dev/ttyUSB1). That works, if the turn the tuning dial, I see data.

But if I try ser2net, I don’t see any data when I connect to the TCP port with a telnet client. If I enable ser2net’s BANNER feature where it sends a text string to the TCP port on connection, I see that string, just nothing when I turn the 7610’s dial.

I am able to use ser2net to relay data from other devices connect to the Pi via USB.

Does anyone know what the 7610 data is not being relayed? Could there be an issue with one of the control lines (RTS, DTR, CTS, DSR, RI, CD)?


Hi Mark.

It’s a while since I last used ser2net but I suspect that it is indeed a handshaking issue. The IC7610 uses no handshaking so in /etc/ser2net.conf I think you should include something like:

serportconfig <tcp port> -XONXOFF -RTSCTS LOCAL

This will disable (-) software (XON/XOFF) and hardware (RTS/CTS) flow control and LOCAL (without -) tells it to ignore the modem control lines (DCD/DTR)

73 Phil M0VSE


Thanks for the reply. Some sort of control line issue was the only thing I could think of. Unfortunately, I tried your suggestion and it’s still not working.


Hi Mark,

There is some outdated information on our old wiki that you might find helpful. Before Phil wrote his wonderful wfview server code, I used to use socat for remote operation.

For anyone else reading this, wfview has a built-in serial server and audio server. This discussion is just around some alternate methods of remote control.

de W6EL