Re-Starting Program Question


Sure do like the new revision.

Here’s something you might want to know about.

I use the program with my Icom 8600. Works great.

I go to bed, but leave the program on, shut the radio off.
Monitor shuts off after a while, but pc stays on (W10)

In the am, I cannot re-connect the program to the newly re-turned on radio.

Always requires closing the program, and re-starting it.
Not that important, but a bit of a pain.
Then it connects just fine.

Am I doing something wrong ?


Hi Bob,

If the radio is fully powered off, then wfview’s “authorization token” that the radio gives out is probably invalid when the radio turns back on. We don’t have any way to really work around that situation other than you disconnecting and re-connecting.

The way I would accomplish what you are doing, is to use the “Power Off” button inside wfview, and, to make sure the radio’s “network” menu setting has “Power OFF Setting (for Remote Control)” set to “Standby/Shutdown”.

With the above mentioned setting enabled, and using the Power Off button inside wfview, I can shut down my IC-9700 (similar to your 8600) remotely from my bedroom. I can then press Power On in wfview to power the radio back on, or, I can even close wfview, put the computer to sleep, open wfview again, and press “Power On” to revive the radio. Keep in mind we have a (long) 3 second delay on power up in wfview, so when you press Power On, it’ll seem somewhat unresponsive for a few seconds while the radio comes up.

I guess the only edge case there is if you have wfview open, Power Off the radio, and then sleep the computer. I’d try it but I’ve got 50,000 things open on my computer right now that I want to finish first:-). If you are in wfview and the Power On button isn’t working, you can try going to Settings, and pressing Disconnect, followed by Connect.

In summary:

  1. Set the radio to “Standby/Shutdown” rather than “Shutdown”
  2. Make use of the Power On and Power Off buttons inside wfview
  3. If it’s really stuck, try Disconnect followed by Connect

Let us know if this helps, and here is an image I stole off a youtube video showing the menu on the IC-9700. I imagine it’s almost the same on the IC-R8600.

de W6EL


Your suggestion works like a charm (as always).

Question: the upper left-side light labeled Power very slowly flashes a weak red when the radio is
“Power Off” per suggestion.

Any idea why, and what it is signifying ?

Is the radio “truly” all off ?

Bob (Icom R8600) and W10

Hi Bob.

That flashing amber LED simply signifies that the radio is in standby mode, similar to how a TV or stereo works.

This allows the radio to keep only the USB and network active while shutting-down all other parts, allowing wfview to connect and initiate a ‘power on’ command.

73 Phil M0VSE

Hi Bob,

Glad it worked! The slow red light just means the rig is in low power standby mode. In this mode, it seems like about half the brain is on and the rest of the radio is powered down, including all the analog stuff. But I really don’t know, it’s a better question for Icom honestly.

If you’re like me and flashing lights annoy you, stick a carefully-cut rectangle of black electrical tape over the LED slot. :slight_smile:

de W6EL

Luckily the color ir not blue because that is really an anoying color in your face. I have a card reader at work that has a blue led but the issue is that the whole plastic holder is translucent so even if you tape off the outside…



Using latest version on W10 pc.
Works just great.
You folks did a truly terrific job with it.

Thought it would be fun to try it out on my Mac. Running Monterey
All sorts of problems. Previous version worked.

I can’t get it to install.

Msg’s come up saying: This software needs to be updated. Contact the developer for more information.

and, “wfview” can’t be opened because Apple cannot check it for malicious software.

Also seems to want to use a program I am not familiar
with to extract the zip : Unarchiver

What am I, as usual, doing wrong ?

Step by step on how to do it would be great. (or, perhaps, a download link I should use instead ?)
I apparently miss many of the “nuances” these days; old age problem.

Best regards, and thanks,