Remote connection set up

Using Win10 64 and can connect / control IC7300 with no issues in USB mode. Struggling to see display or evidence of connect with remote laptop on LAN. I have set user and password access and see that the host PC has appropriate Window Defender FW settings for the moment ‘Private’ network. Also I have enabled the remote service. I’m assuming that my laptop will also need permissions in local FW but can’t see WFView as an app to assign privileges to and FW is not listed as having port 50001 in my laptop’s firewall. Is that needed? Both client and host computers display the correct LAN IP address and 50001 is seen as controlling port in WFview. So it does appear to have communicated and recognised, but I can not see waterfall or evidence I have connected. Anyone able to advise me?

Please turn off all the firewall software on both sides, at least temporarily.

Try to connect again. If not successful, please send us the log links for both the server and client sides. You can do this from each side using the Log button and then pressing “send to termbin”

de W6EL

Thanks Elliott

I’ll give that a go and report back

Best Regards

Alastair G4NUO

Tried disabling firewall on both PCs and no success. Log files sent annotated with my callsign.

Alastair G4NUO

You’ll need to send us the URL that is given to you when you press “send to termbin”.

It is already copied to your clipboard, you just paste it in here. From both server and client sides please.


Hi Elliott

Server side:

Client side:

Hope I have done this correctly

Appreciate your assistance

Best Regards

Alastair G4NUO

Hi Alastair.

A few points from your log files, firstly the server log:

2023-03-02 16:07:33.188 INF system: Skipping automatic CIV, using user-supplied value of  148

This tells me that you have manually specified the CI-V address for the radio, rather than letting wfview detect it. This is not recommended, we always recommend that users enable CI-V Transceive on the radio and allow wfview to detect it.

2023-03-02 16:07:32.766 INF audio: "Server Audio input device Microphone (4- USB Audio CODEC ) found! "
2023-03-02 16:07:32.766 INF audio: "Server Audio output device Speakers (3- USB Audio CODEC ) found! "

This seems to suggest that you are using a different audio device for Server input and output audio (in Server settings) these would usually be the same device.

On the client side:

2023-03-02 16:18:37.518 INF udp: Error obtaining IP Address for : "IC 7300" :  "Invalid hostname"

You appear to have entered “IC 7300” for the IP address/hostname of the server? This should be the server IP address (which according to the server log is

If you fix the above, I can’t see any reason why it shouldn’t work.

73 Phil M0VSE

Thanks Phil

That’s interesting. I did have it set up pretty much as you said it should and then messed around. I’ll revert all settings and try again tomorrow. I wondered about CI-V 148 and where that came from. All should be same USB Audio CODEC, I agree but I’m sure that’s how I set it up. I have installed and uninstalled more than a couple of time and there may be some residual settings. I’ll try all again. Many thanks for quick response.

I am taking it that the spectrum display should come alive on the client PC if connection is made successfully?


Alastair G4NUO

Hi Phil

Here are latest log results. Still no connect. Have yet to try using disabled firewall but seems there is a response from server. Just no control or display.

Are there settings I need to make in External Control? I would have thought not.

All PCs running on 64 bit Win 10 and all have correct version of WF installed

Can you see anything wrong in the following?

Server settings

Client settings


Alastair MacKenzie

I’ve now solved this. Server PC was using port 50001 for something else so there was a port clash. Changed default port to 60001, 2, 3 and all is well

Ah yes that will do it. Wfview should do better at detecting port conflicts, but it is quite complicated as not all operating systems allow exclusive use of a UDP port. So we might not be able to detect whether we have got exclusive access to it or not.

73 Phil