Rpi 3b and wfview

Hi All,

  1. Elliot, your script worked fine for Raspian on the Pi 3B. Thanks!
  2. Using LAN to IC-705, using amixer, patchy sound to the pi speaker jack, nothing to the HDMI audio. Otherwise looked ok.
  3. Using USB to IC-705, no auto recognition of USB (or rig ID). USB turned out to be ttyACM0.
    Waterfall slow with plenty of loss, no rtt or packet trackers lower right.

I’m hoping to use a Pi as a server with my 7300. Guess it will have to be a Pi4 with 2? 4? GB.

Great program, lots of fun. Thank you!

Bill ab4tc

Hi Bill,

Glad the script worked!

For the IC-705, you really will get the best experience if you use the network access capability of the radio. Just get the IC-705 to join the same network as your Pi. The spectrum over USB is considerably limited in speed by Icom in order to accommodate whatever other traffic might be present on the line. We will work on the auto-discovery for the ttyACM0 port, that’s a good point there.

As for the 7300, I have one running with wfview as a server on my linux pc. It does work! However, there are some issues with the audio that we are working through, so you may notice things are a little odd the first time around. I would say go a head and try getting it working, because this is an area that we are working on a lot and you will see improvements soon.

I think 2 GB might even be enough, but probably worth springing for 4 GB.


de W6EL

not the same here. If I compile on rasp 3B make -j hangs.
if I do the same on raspi 4 I get:

g++ -c -pipe -s -fvisibility=hidden -fvisibility-inlines-hidden -faligned-new -O2 -Wall -W -D_REENTRANT

 -o moc_rigcommander.o moc_rigcommander.cpp
g++: fatal error: Getötet signal terminated program cc1plus
compilation terminated.
and all following components are killed also. If I repeat `make -j` it stops at `moc-udpserver.cpp`. The 3rd time it stops at `moc-repeatersetup.cpp` on other tries it shuts down the raspi. There are a lot of parallel g++ threads. It looks like overload (?). What can I do better? Thanks Andreas

Hi Andreas

I find that make -j needs an 8GB Pi4. For anything less, use make -j4 to limit it to 4 threads.

73 Phil

:+1: :wave: Thanks! Andreas