Workaround to no audio on startup on Win 10 for IC-705

The transmit audio is still flaky with version 1.55. After a few minutes it starts to fluctuate / drop out.

Check your log for network issues (missing or re-transmitted packets).

Also, disconnect and:

  • Change the sample rate to 16k
  • Change the format to uLaw 8-bit
  • Change the latency to 200ms for both TX and RX.

(and then connect again)

That’s my advice for more reliable audio.

–E
de W6EL

“Also, disconnect and:

· Change the sample rate to 16k

· Change the format to uLaw 8-bit

· Change the latency to 200ms for both TX and RX.”

With those settings, it doesn’t work at all. I never get any audio sent to WSJT-X on transmit, even when I try the workaround.

I put it back the way I had it:

Sample rate: 48000

Format: LPCM 1ch 16 bit

And left the latency set to 200ms for both TX and RX.

Then it works initially, but then the audio starts to fluctuate and/or drops out as usual. The workaround will only restore things for a few minutes then it goes back to being flaky.

Think I will buy the Icom RS-BA1 software and be done with it.

Wondering if you rebooted after making those setting and then tested? I find that I need to reboot after changing some settings like audio settings.

This is almost certainly a network issue and changing software is not likely to help!

It is worth checking the log at the point you start to experience audio dropouts, I am betting that there are retransmissions occurring?

How are you connecting to the IC705? If using the internal AP mode, this is known to be VERY flaky. I use a good quality wireless access point (Cambium) and have no problems at any format/sample rate over many hours.

73 Phil M0VSE

@kh6idf – let us know if the use of RSBA1 makes your life better.

I have with my mesh network here a lot of TX audio problems on the 705 as wireless client when using RSBA1. If I use wfview it gets better though (linux) . Now. if I shut down all the access points except one, all goes fine with both TX as well as RX. RSBA1 drops a bit more but it’s not a big issue.

It’s a well known issue that 705’s forte is not the wireless performance. It drops easy the ball if you are 10m from the AP.

ps be sure to get RSBA1 v2 !

I’m using “Station (Connect to Network)” to connect the 705 to my home wifi network.

I seem to have a stable configuration now, I have been running WSPR on 17M for over an hour and it’s still working. My settings are:

RX/TX latency both 200
RX/TX codec both LPCM 1ch 16 bit
Sample rate 16000
Audio System QtAudio

I do have some packet loss, 498/275371
rx latency is 171 ms, rtt is fluctuating but is usually 10ms or less.

1 Like

Great that you got it working, reducing the sample rate to 16000 will reduce the required tx and rx WiFi bandwidth by around 60% with practically no noticeable difference on a ~3Khz passband. Elliott’s recommendation for uLaw is also (usually) a good one as that further reduces the bandwidth by another 50% while also reducing the packet size. Again there is very little loss of audio quality as uLaw is effectively 12bit audio compressed into 8bit. I suspect that uLaw may be broken in master at the moment (which is what the weekly builds are compiled from). It is definitely working in my development branch which should be merged to master soon, it also includes a number of additional audio fixes.

Your RTT is a bit high, this is likely due to the distance that the IC705 is from the access point. I typically get 1-2ms RTT and have latency stable at under 80ms, but my IC705 is less than 2m from my AP. As Roeland said, WiFi really isn’t the IC705’s strong point! If you have the capability, it might be worth running a WiFi scan and move your AP to the least congested channel you can find (although 2.4G WiFi doesn’t give you many options in this regard)

73 Phil M0VSE

I installed a high quality mesh network, but found that my sprinkler system that used UDP packets was unreliable. I unplugged the 2nd mesh network router and my issues dissipated.