1.2d beta released

the following highlights are in this 1.x-release:

    many changes/mods/updates/enhancements to rigctld
    rigctld box added in the UI
    build process changed: you  can add the install prefix (derSuessmann)
    added "do not ask again" for switching off rig and exiting wfview
    added opus as audio transport 
    dual meter support
    rigctl basic split support
    rigctl prevents switching off civ transceive
    added 25 kHz step
    as a temporary measure sending multiple TX/FREQ change commands to the rig
    when we use rigctld. 
    people should use "fake it" in wsjtx as the split code is not reliable.
    tidied up udp server function for better reliability
    added some IC736 stuff
    added portaudio (you need t change wfview.pro to select 
    and that lowers the latency to maybe less than 50 ms
    added PBT and IF-shift
    several bugs fixed
    RTS as PTT for several radios like the 706/718/736…


Thanks for the new release! I hope FT8 will work flawless now with my 7300, hi.
Do you need to uninstall the older version first before installing this one?
There is no instruction or remark in the manual, maybe it’s good to mention to avoid misunderstandings?

73, Fred

Hi Fred.

No you shouldn’t need to remove the old version as the installer will overwrite it.

73 Phil

Phill/Elliott, is the Debian (Raspberry Pi) version ready?


Hi Michael,

It should be just fine, can you download the build script and give it a go?


de W6EL

Just upgraded to 1.2d on the Raspberry (server) and Surface Pro (client), both working great. No rig control or frequency shifting issues so far.

Thank you!

Edit: I tried portaudio, but none of the options under “Audio Output” seem to work. I can decode just fine using any of the 3 available options under “Audio Input”.


Hi Jeff,

That’s good to hear it’s working! With the portaudio option, sometimes there are issues with exclusive audio device access. It’s a new area for me. You may want to try a few times and also check the log file for useful audio messages.

de W6EL

Downloaded and installed, Windows version.
As with 1.2c (tried on another computer) I had to download and install 1.1 first before upgrading, due to installer not finding vc_redist.

Congratulations, once more your software is working fine here. 1.2D is quite stable on my config.

Wfview is absolutely necessary on my set : IC-705 (by WLAN to Wfview, then by virtual serial port to Wsjtx and Cqrlog thru Wsjtx) with Linux Mint.

That way I can get rid of the USB connection which is a good source of QRN on the 705’s receiver .

I have found that - following some topics here- the Wifi link must be strong enough to prevent a lot of packet losses after few minutes and thus WSJTX’s lost of link.

Thanks a lot for your brilliant work.

Best 73

Nicolas, F4IPL

1 Like

my experience is that the 705’s wifi works well (enogh) when you are next to it and connected directly; if it’s about 6m apart here stuff gets unstable.

If joined to the AP here it works fines long as it’s at most 8m from the AP here.

If I use a mesh-network, things become mess(h)y – and ICOM mentioned that the curent wifi stack does not support a mesh network.


I’m curious about your comment regarding the QRN from the IC-705 USB connection. What is this QRN? What bands do you hear on QRN? Does the NB remove the QRN? Was the USB cable installed with ferrite clamp-ons at both ends of the connection?


Hi Dave.

I would say it is more QRM rather than QRN… I have experienced the same thing, I suspect that the IC705 has little (or no) isolation on the USB port. By using a USB isolator and ferrites wrapped round both ends of the USB cable, I have been able to significantly reduce the level of USB borne noise but without them, the noise level from USB makes the rig unusable.

I suspect that it also depends on how much isolation the computer provides to its USB ports? I have found that the Raspberry Pi is particularly bad in this regard.

73 Phil M0VSE


This is good information. I don’t use the usb port to connect to the LAN. I’m a wireless advocate.

Thanks for the fast response,

I experienced the same problem during the install as LB3FJ.

Downloaded and installed, Windows version on server pc…
As with 1.2c I had to download and install 1.1 first before upgrading, due to installer not finding VC_redist.x86.exe
Installing 1.2d on my Windows laptop (client), no error detected during installation.

Any idea why the Windows pc fails to install while the Windows laptop shows no install failure?
73, Fred


Here some info about the tests I’ve done today.


TRX: IC-7300
PC : Raspberry PI Modell 3 (1.2 GHz), LAN
OS : Raspbian OS Bullseye
SW : wfview 1.2 compiled from source 7. Dec. 2021
Server enabled

PC : Lenovo E595, Ryzen 3700, WLAN
OS : Windows 11 Pro
SW :
wfview 1.2d installed 7. Dec. 2021
Rigctld enabled, wsjt-x 2.4.0 (wspr, FT8) via hamlib and vb audio cables connected.

Compiling at Raspi wfview from source => ok
Installation on Windows => ok, I ignored error of missing VC_redist.x86.exe. I don’t know if it is important or not, because I’ve so many times installed other developing SW like Visual Studio, Python and Qt etc., that I can’t tell.

On Raspi cpu usage is:
wfview 45-50%
pulseaudio 9-11%

Connection: (LAN and WLAN)
udp stream rx 168-176 kBit/s, tx 112-120 kBit/s with codec Opus 1ch
rx latency 80-92 ms / rtt: 4-15 ms / loss: 0/218000

Connection: (LAN and LAN)
udp stream rx 168-176 kBit/s, tx 112-120 kBit/s with codec Opus 1ch
rx latency 17-20 ms / rtt: 0-1 ms / loss: 0/220000

Thank you for these fine program and your time you spent to enable it.

FYI>> Never had any problems using our local WiFi with the IC-705 and/or IC-7610. Our networks is using two Asus routers setup in Mesh configuration.

This is using Wfview or Icom RSBA-1.

73… Ken - VE5KC

good to know Ken; the mesh issues may or may not arise when moving the 705 around the building where stuff may become an issue.

(the 705 detects multiple same-ssid’s and switching over between them does not work well.)

Hi, this may be my craze, but I notice that the latest beta, compiled directly from the source code of the main branch, does something I hadn’t noticed before.
I have set up WFview as the front end of my computer, but if I’m in front of the radio, I use the radio buttons and not the WFview buttons.
I’ve noticed that if I turn on the transceiver via the power button, sometimes WFview doesn’t see it, and it’s still “sleeping”. Then I press the “power on” button of the program and the water fall and the frequency appear correctly. That doesn’t matter anymore, but I swear it didn’t happen before.

If I have a while, I will try to put an old version and watch it calmly.

Hi Jordi,

Do you leave the same instance of wfview running between radio power cycles?

de W6EL

Yes, I start WFview one time when star my PC. Some times, run for a week the same instance.

Add a short video about this “efect”.