7300 no WFview

Ok here we go:
I have a 7300 that I have set up using the docs for the wfview set up on this radio.
I did have Wfview working and did a complete reinstall to a new computer. (Win10) I installed the driver and used the same settings for the server. But the server shows time outs and no connectivity to the radio.
Any help appreciated!

Hi Bud,

Remind me, what OS for the client and server? Can you ping reliably from the client computer to the server computer? Are they on the same LAN?

You might want to try the latest weekly or nightly build, there’s a lot of action going on right now with the server code.

–E
de W6EL

Hi Bud.

One thing, can you check what COM: port address the IC7300 has been assigned? If this is a new computer, it may be different to the one that was assigned on your old machine?

This is accessed through Device Manager (on Windows 10 you can right click on the Start Button and select Device Manager). Whichever port it is, needs to be selected within wfview.

I can ping the server. Running Win10 on both.
Client does not connect to server using ports 50001 thru 4.
Checked ip Addy and name and passwords.
When connect is pushed message on on button says searching for cv I connected radio.
Also have latest install.

Hi Bud.

In the pictures that you sent me last week, I can see that the wfview client IS connected to the wfview server. This is shown by the rx latency: … line at the bottom of the wfview window.

This means that you have the client <> server connection working OK so the problem is most likely the connection to the radio itself. I assume that you don’t see the waterfall on the ‘server’ machine either?

Can you post the log files from both the client and server machines? Log file | wfview

73 Phil M0VSE

The server is working great as far as I can tell.
Some things to note, a Windows update occurred the other day.
Client side no longer shows the RX latency any more.
Log of client:
PS C:\Users\Hoth> Get-Content $env:TEMP\wfview.log -Wait -Tail 30
2022-01-18 21:34:51.325 INF system: “wfview version: 1.2d (Git:b1ef680 on Dec 4 2021 at 16:45:57 by build@wfview.org)\nOperating System: Windows 10 Version 2009 (i386)\nBuild Qt Version 5.15.2. Current Qt Version: 5.15.2\n”
2022-01-18 21:34:52.697 INF default: setState 1
2022-01-18 21:34:52.697 INF default: setState 0
2022-01-18 21:34:52.697 INF default: setState 1
2022-01-18 21:34:53.452 INF system: Loading settings from “\HKEY_CURRENT_USER\Software\wfview\wfview”
2022-01-18 21:34:53.499 INF gui: Got Audio Output: “”
2022-01-18 21:34:53.499 INF gui: Got Audio Input: “”
2022-01-18 21:34:53.515 INF default: Getting server config
2022-01-18 21:34:53.637 INF system: Cannot prepare WF view without rigCaps. Waiting on this.
2022-01-18 21:34:53.637 INF udp: Starting udpHandler user: “hoth” rx latency: 150 tx latency: 150 rx sample rate: 48000 rx codec: 4 tx sample rate: 48000 tx codec: 4
2022-01-18 21:34:53.653 INF udp: UDP Stream bound to local port: 62426 remote port: 50004
2022-01-18 21:34:53.715 INF system: Received CommReady!!
Server config:
PS C:\Users\mr_ho> Get-Content $env:TEMP\wfview.log -Wait -Tail 30

2022-01-18 21:43:02.658 INF system: “wfview version: 1.2d (Git:b1ef680 on Dec 4 2021 at 16:45:57 by build@wfview.org)\nOperating\nOperating) System: Windows 10 Version 2009 (i386)\nBuild Qt Version 5.15.2. Current Qt Version: 5.15.2\n”

2022-01-18 21:43:03.360 INF default: setState 1

2022-01-18 21:43:03.360 INF default: setState 0

2022-01-18 21:43:03.360 INF default: setState 1

2022-01-18 21:43:03.808 INF system: Loading settings from “[\HKEY_CURRENT_USER\Software\wfview\wfview](file:///\HKEY_CURRENT_USER\Software\wfview\wfview)”

2022-01-18 21:43:03.861 INF gui: Got Audio Output: “”

2022-01-18 21:43:03.861 INF gui: Got Audio Input: “”

2022-01-18 21:43:03.877 INF default: Getting server config

2022-01-18 21:43:03.961 INF system: Cannot prepare WF view without rigCaps. Waiting on this.

2022-01-18 21:43:03.961 INF system: Cannot prepare WF view without rigCaps. Waiting on this.

2022-01-18 21:43:03.961 INF serial: Opened port: “COM3”

2022-01-18 21:43:03.961 INF serial: Could not open pseudo terminal port, please restart.

2022-01-18 21:43:04.024 INF system: Received CommReady!!

2022-01-18 21:43:04.024 INF system: Delay command interval timing: 75 ms

2022-01-18 21:43:04.024 INF rig: Using incomingCIVAddr: (int): 148 hex: 94

2022-01-18 21:43:04.024 INF serial: Received rigCapabilities for “IC-7300”

2022-01-18 21:43:04.024 INF rig: Have rig ID: decimal: 148

2022-01-18 21:43:04.039 INF system: Delay command interval timing: 25 ms

2022-01-18 21:43:04.710 INF system: Could not find modulation input: 2

2022-01-18 21:43:05.443 INF system: Could not find modulation input: 2

2022-01-18 21:43:06.161 INF rig: Received 0x15 center span data: for frequency 100000

Hi Bud.

Is there any reason why the client is connecting to port 50004 rather than the default of 50001? What ports have you configured on the server (within the server setup window)? The control port MUST match that set on the client and different ports MUST be configured for CIV and Audio. The default is 50001 for Control, 50002 for CIV and 50003 for Audio.

If you are not getting any latency, this is usually because the Audio connection is not being made (the default audio port is 50003). It is possible that another program running on either the server or PC is already using this port so maybe try 3 completely different ports on the server?

73 Phil M0VSE

Looking on your log, it looks like the Control connection to the server isn’t being made which suggests a conflicting port, this is a log from a successful client connection for comparison:

2022-01-15 17:20:06.603 INF udp: UDP Stream bound to local port: 59663 remote port: 50001
2022-01-15 17:20:06.605 INF system: Received CommReady!!
2022-01-15 17:20:06.605 INF default: Setting rig state for wfmain
2022-01-15 17:20:06.605 INF default: Setting rig state
2022-01-15 17:20:07.131 INF udp: udpHandler : Received I am here from: QHostAddress("::ffff:192.168.99.143")
2022-01-15 17:20:07.132 INF udp: udpHandler : Received I am here
2022-01-15 17:20:07.136 INF udp: udpHandler : Received I am ready
2022-01-15 17:20:07.136 INF udp: udpHandler : Sending login packet
2022-01-15 17:20:07.142 INF udp: Got connection type: “WFVIEW”
2022-01-15 17:20:07.142 INF udp: udpHandler : Received matching token response to our request
2022-01-15 17:20:07.143 INF udp: udpHandler : Detected connection speed WFVIEW
2022-01-15 17:20:07.147 INF udp: udpHandler Received radio capabilities, Name: “IC-705” Audio: “ICOM_VAUDIO” CIV: a4
2022-01-15 17:20:07.147 INF default: Received serial port baud rate from remote server: 115200
2022-01-15 17:20:07.147 INF system: Delay command interval timing: 75 ms
2022-01-15 17:20:07.153 INF udp: Starting udpCivData
2022-01-15 17:20:07.153 INF udp: UDP Stream bound to local port: 63015 remote port: 50002
2022-01-15 17:20:07.153 INF udp: Starting udpAudio
2022-01-15 17:20:07.154 INF udp: UDP Stream bound to local port: 52920 remote port: 50003
2022-01-15 17:20:07.154 INF udp: udpHandler Got serial and audio request success, device name: “IC-705”

Is there a certain port on the server that should be open?
I changed the client to 50001 and rebooted the client to no avail.
Thanks

Remember when all else fails, ham radio will still be there.

Hi Bud.

That depends what is configured within the Server Setup window (server setup button in settings page). The control port you configure on the client machine MUST match the control port configured on the server. In addition you must ensure that no other software is using this port (or the ports configured for civ and audio)

image

GOT IT!
Windows 10 was blocking WFview in the firewall.
Thanks for all the help!

Remember when all else fails, ham radio will still be there.