7610 Remote via LAN + Wfview + WSJT-x + COM0COM + Jack2 on Win10 HELP

Has anyone had success on Windows 10 running Wfview + WSJT-x, and using COM0COM and Jack2 (or Jack1) as needed to connect to a remote IC-7610 across a LAN. I have made over 8500 FT8 and FT4 contacts using the ICOM Remote Util and WSJT-x. I use RS-BA2 instead of WSJT-x to check settings and SWR, since I use a remote tuner.

I would like to expand my repertoire to include CW decoders and keyers. Also, it would be nice to not have to exit WSJT-x to run RS-BA1 and vice versa, since they both cannot use the COM port to control the IC-7610 simultaneously…Yes, I have used RS-BA1 on CW, but my hearing and confidence in copying CW is lacking — hence wanting to run CW decoders the same time as other software.

I do have an RC-28, which is great for SSB or CW tuning and works with the RS-BA1. I haven’t seen anything about it working on Wfview.

I am running (or wanting to run) this on a Dell 7480.

I have installed all the software I mentioned on my Dell, and have Wfview working with the IC-7610. But I can’t seem to go any further.

Bob NQ5P

1 Like

Shows the connection working between IC-7610 and Wfview across WiFi and LAN.

Shows my Wfview LAN+Audio settings for the connection to the LAN connected IC-7610

Are these settings correct to make Wfview a server to connect WSJT-x to? Note this shows COM0COM virtual port connection.

COM0COM virtual port pair. Is this correct?

My WSJT-x settings. Note I am trying 115000 baud, same as I used with ICOM Remote Utility and WSJT-x. When I Test CAT, it goes red after a while and I get a hamlib error.


I do get a Rig Control Error popup, and the freq setting is red and zero. There is no waterfall showing on the WSJT-x Wide Graph.


Sorry, I do get a waterfall with WSJT-x, but it looks noisy and wrong. Plus, I am not getting decodes.

Jack2 settings, but I don’t think is being used.

Hi Bob,

Wow, there is a lot to unpack here. But I do appreciate the details you have sent and the screenshots.

First, our manual, have you checked it lately? Specifically this page on Sharing Control. The recommended method for WSTJ-X is to use wfview’s built-in rigctld. If you look at our rigctld page, you can see how to configure wfview and how to set up wsjt-x. This method works really well and is very easy to setup. It does not require any virtual serial ports. The virtual serial port method is recommended as a “last resort” when nothing else will work. With that said, it should have worked, and maybe someone here with more microsoft windows experience can comment on your settings.

As for audio, have you read our chapter on Audio Configuration? Give that a try, the method detailed there works for many people. If you’re not getting decodes, my guess is that wsjt-x may have been looking at something less direct such as room audio. But I can’t be sure.

The RC-28 is not supported yet, although we have plans to do so. We just need someone to send one to @phil. We also have plans to support the ShuttleXpress and ShuttlePro.

wfview does not provide any specific CW support, although you can of course use programs like fldigi to do CW using the rigctld control method with audio loopback. There may be some other more advanced tricks to get that working that I am not aware of.

de W6EL

I did read over the manual, but was probably getting glassy eyed.

I liked all the input and will give those suggestions a try. I do have rigctl installed and tried it prior to trying wfview.

I like that I don’t need virtual ports!

It isn’t room noise, because I have the speakers off and the room is quiet, and scratching on the mike doesn’t change the level or waterfall. I do see a good signal on the WSJT-x level meter.

Thank you so much! I will report back.

You do not and should not run rigctld.

Read the manual carefully. We have a rigctld-compatible server inside wfview, and if you enable it, then wsjt-x can connect to it.

Let us know how it goes,

de W6EL

Thanks for the reminder that wfview contains rigctl! I sort of recall seeing rigctl mentioned, but at the time was looking for another solution.

And, I may have accidently started the built in rigctl while playing around with wfview. I saw a rigctl screen behind other windows and I was wondering how that got started.

I may work on this project tomorrow, but if not it may be a week or so away while I take care of some health issues.

WSJT-x and CWTY (decoder) are both working simultaneously on receive with Wfview (and with embedded rigctl). After some experimentation, I was able to transmit with WSJT-x and made several FT8 contacts.

As I was walking back thru the configuration and preparing to document my settings, Wfview window disappeared. I was able to restart. Eventually after disappearing I was unable to restart. I did see that it still held a lock on my IC-7610 (was logged in still). I was unable to restore the Wfview window and eventually power cycled my radio and rebooted my Dell 7480. Now each time I start Wfview the window comes up for about 3 seconds then disappears. I cannot turn on Debug in the 3 seconds. I am getting the log file and will post it, but it doesn’t provide any hints to me as to why the program exited early. Everything seems to be working, including the connection to the IC-7610.

Looking forward to the new audio code and the RC-28 support.

Here is the log file:
wfview-20221207101458.log (3.5 KB)

I was able to start wfview in a command window with the --debug option, and obtain this debug log file. I see the gap (with udp audio packets I assume) at the end, but I don’t understand why this is killing wfview.

Suggestions? Next steps?

wfview-20221207130140.log (6.1 KB)

Hi Bob,

I’m puzzled as well! The log doesn’t show anything terrible as far as I can tell.

Can you try our latest weekly public build? You can find a link and directions on the Downloads page. Perhaps this is a bug we have already fixed. I see you’re running version 1.5 from September.

de W6EL

I moved to the nightly build 20221205-03-00-01, and installed the QtXml.dll, and the portaudio_x86.dll to try to make it all work. With the Qt audio system, I cannot get transmit audio from WSJT-x. With the port audio system, Wfview dies in about 3 seconds. Previously with the Sept stable version I was able to transmit and have QSOs for a time from WSJT-x connected to rigctl using Wfview’s port audio system. That is, until it started dieing.

I hope this information is useful. Again, I am using a Dell 7480 Lattitude and Windows 10 Version 22H2 (OS Build 19045.2311). All is running across my Wifi and LAN to an IC-7610.

as a general sidenote – be aware that Dell may come with maxxaudio pro by waves.
That may at some point become an audio issue if it is going to be postprocessed (like
when using wsjtx etc)

You are correct, but my understanding is that Waves Maxx Audio is not required for a headset on older models like mine. I have tried it but since uninstalled it. No matter what I did, I was not able to get my cabled headset microphone to work. I do have the TRRS adapter to switch between the Apple and PC wiring (Mic and Gnd switches) At one time, I think this worked. So I plan to use a bluetooth headset when I run SSB.

Thank you!

I’m going to close this topic, and start up new topics if I need to. The title is now wrong for my system.