Audio feedback during transmit

So I am trying Wfview with an IC-9700 cnnected remote via WLAN. Receive is working properly but during transmit there is a whistling tone which increases with time and is pumping in SSB - even with no microphone connected. It appears to me like a loopback…

Any idea ?

when you say mic no connected – is this remote at the wfview end or local at the rig?

a wild guess is that your volume is not closed at the rig and you have moni on but then again… wild guess.

I’m running my IC 9700 remote over LAN with no such issue. My wild guess is here a ground loop router/ switch and the rig

Do you have “Monitor” turned on? This is the radio’s built-in loopback feature. Turn it off if it is on, using the radio’s controls.

Is LAN selected as the audio source? What happens if you turn the LAN slider all the way down?

What, exactly, is selected in the wfview client as the audio source for transmit audio? Receive audio?

Do you have “monitor” or “play through” or similar enabled anywhere in your OS audio settings?

de W6EL

Thanks so far for the responses.

  • No it is definitely not a ground loop.
  • When I wrote “Mic not connected” I meant the mic which is on the wfview end.
  • At the rig is definitely no mic connected (verified).
  • I don’t know at the moment if monitor is (accidently) left on… the radio is “remote” and when I write “remote” than I mean that this is not in the next room or in the basement. Therefore it is currently not possible to change anything on the radio (until I have build a mechanical remote device to push a button remotely :wink: )
  • LAN is selected as the audio source
  • When turning the LAN-slider all the way down, the noise disapears.
  • Audio Input: Microphone (High Definition Audio Device)
  • No “monitor” or “play through” on my OS enabled
  • BTW, I am running wfview 1.2c
  • The sytem was previously already running on an other computer without problems
  • Maybe the radios “Monitor” has been accidently left on… currently not an easy task to change this…

If the LAN being turned up is changing it, then the audio is flowing through the 9700. The only way I know to cause this is for the built-in monitor to be enabled. It would have a little stutter before full-tilt feedback would set in.

It only happens when you transmit, right?

FYI wfview streams audio full-duplex the entire time. So when you transmit, that is the moment where the radio begins the built-in monitor function.

I don’t quite understand why that is causing feedback, but it seems likely to me that it is part of the issue.

I should also ask, are you running dual-VFO, and if so, could the sub receiver be receiving the main receiver?

de W6EL

  • It is/was only when transmitting
  • only single VFO

Many thanks for all the advices. Fortunately I could solve the problem:
It was the built-in microphone.

So I wanted to use a netbook with built in microphone (and an external mic jack).
Normally one could expect a single audio-input-device which switches off automatically the built-in mic when using an external microphone. Not in this case. There were two audio-devices, one the internal mic and the other the jack for the external mic. Both were activated and caused an audio-feedback with the built-in speakers. (I know, why I don’t like laptops :wink: )

After deactivating the internal mic, the feedback disappeared.

1 Like

Excellent! You’ll probably sound a lot better with an external mic anyway :slight_smile:

de W6EL