Audio heavily distorted on client side

I had it setup with good quality RX audio on the client side but no TX audio. Trying to troubleshoot the TX side I lost the good quality audio on RX. Now it is heavily distorted. I have revisited every thinkable setting in Wfview on both sides (including reselecting devices) and on both PC ends but audio is still distorted (and no TX audio).
Wfview version 1.5
Server: Win 10, latest release
Client: Win 11, latest release
Audio system on server: QT or PT. Doesn’t matter.
Audio system on client: QT=silent, PT=used to work but now distorted.
73’s - Ulf - SM0NOR

there are os sliders, check them out… many times it is the case of distorted audio.

also disconnext, try a different audio stack like rt

Levels no problem. I’d say “garbled” is a better word than distortion which is something else.
I will try uninstalling Wfview and clean the windows registry. That might help.

Hi Ulf.

I can’t really think of a situation where uninstalling wfview will fix anything. You can try manually running wfview.exe with the –settings command line option to use an .ini file for settings. Command-Line Arguments | wfview

We have discovered a situation where audio devices that contain non-ascii characters in their names are not being correctly enumerated. This has only recently come to light as none of the core developers have this issue. In older versions of wfview, it would simply revert to using the detected default device if the selected device wasn’t found, but that hasn’t been happening since 1.2e when audio handling was rewritten.

There is currently a fix in the master branch and in the next few days, a weekly build containing that fix should be created. The weekly builds can be downloaded from just download the .exe and replace wfview.exe with the file.


Phil M0VSE

You’re. It didn’t help. Only tried on the client side. I’ll try on the server side also.
Hard to know if the problem is on the server or on the client.
Strange though, because it did work before I started to troubleshoot TX audio.

BTW… Where is the settings file stored?

I also got this error during install. Actually, on every install… but I pressed ignore
Cannot start: “C:\Program Files (x86)\wfview\vc_redist.x86.exe /passive /norestart”: Process failed to start: The system cannot find the file specified. Retry|Ignore|Cancel

Manual settings files will be stored in your %APPDATA% folder unless you supplied an absolute path.

Incidentally, Elliott has run a weekly build early so you could try the latest build (dated today) in Index of /public_builds/ just download the .exe and copy it to your wfview directory (you can overwrite the existing wfview.exe or leave it in place)

If this doesn’t work, it is possibly because of a sample rate or codec issue, a recording of the audio might help us narrow it down. Wfview will attempt to convert to the native sample size/rate whenever possible but there are so many different hardware/software combinations to take into account so it gets very complicated.

You can safely ignore that warning, It seems to happen with certain users, I’m really not sure why as none of my machines do it!

73 Phil M0VSE

I would also recommend using Qt audio in Windows if you can.

Audio is back now after deleting all registry keys in windows registry.
I could not find any user setting in APPDATA. But after deleting registry keys as above everything was reset and audio came back after reconfiguring.
Now I can continue to troubleshoot the no TX audio thing

That one is totally silent on Microsoft Surface Laptop 4. But Portaudio works

Hi Ulf.

wfview will only create an .ini file if you manually run it with –settings <filename.ini> otherwise it uses the registry. If you use the –settings or -s option, the registry isn’t used at all.

By default, this is stored in QStandardPaths::AppDataLocation which in windows is the roaming appdata directory c:\Users<Username>\Appdata\Roaming

73 Phil M0VSE

Did you download the latest weekly build like I suggested?

Now! I had the one dated 0926. I found today’s 1001 now. It seem TX audio is working now.