Audio System Field Blank

Hi Folks,

Just loaded v1.61 on my MacBook Air. MacOS v12.6.3 (Monterey). I have 3 mics available. The built-in laptop mic, a USB desktop mic and a Bluetooth headset. Wfview does not recognize the Bluetooth headset mic unless I also plug in the USB desktop mic.

But i think my first problem is that the “Audio System” field is blank for all mics even if I disconnect the Bluetooth and USB mic (with just the laptop built-in mic). I also see no input devices at all if the USB mic is not plugged in.

Note that the Audio System field is always blank for any of the mics.

Thank you for your wonderful product and your support. Best in the business!

Dan N1DH

Hi Dan,

Can you send us a link to your log file? This is quite interesting.

Press Log and then press “send to termbin”. When the URL comes back, paste it into your reply here.


de W6EL

Hi Dan,

This is very interesting. I see the RT Audio audio system is running. I also see that your settings haven’t been saved in a long time (likely since version 1.50). It may be prudent to try erasing your settings and starting fresh. But only do this if you feel comfortable.

Your settings file is:


You can close wfview and back that file up and then remove it, open wfview, and then set things up the way you wish.

Or if you want, wait for @phil to tell us what he thinks it is. I’m not really sure, to be honest. But the three audio systems, QT Audio, RT Audio, and Port Audio, they should all three show up as available choices. And QT Audio would generally be my first choice when it works.

de W6EL

Hi Dan.

Looking at your log, the device “HW01” isn’t reporting any supported sample rates, which is very strange. I have never seen this so it is likely some compatibility issue with the hardware.

Are you sure that the “Audio System” combobox is blank? It is disabled while connected (or attempting to connect) to a radio. If you press the “Disconnect” button, it should then be enabled and allow you to select from the 3 different options.

73 Phil

Hi Phil,

Sorry for the delay, I watched the Super Bowl (the refs lost—again!) and then fell fast asleep.

You are correct, the Audio System field is enabled by choosing disconnect. I now have the 3 choices.

But, an interesting aside, I downloaded v1.61 again and renamed the settings file (by putting an “X” in front of the filename). Sure enough, the settings were now gone when I fired up Wfview. However, I quickly found out that I had forgotten the server name (7610) and my username and password. So i thought, no sweat, I’ll just rename the NEW settings file and set the old settings file’s name back to it’s original name. No Go! I have somehow lost all of the original settings. No worries though, I did it once before and I can do it again. Now where did I put those Getting Started instructions again?

Thanks so much for the help Phil. I will update this incident once I get wfview connected again.


Dan N1DH

That’s likely a protection mechanism employed by the operating system in case of malicious code attempting to replace configuration files.

73 Phil


I’ll use Time Machine to recover…

Dan N1DH


OK, back on the air (sorta).

I still have the blank Audio System field problem. This is probably a PICNIC issue (Problem In Chair - Not In Computer). I see it set at Qt Audio

when the radio is disconnected but it goes blank when I connect the radio.

Any thoughts?

Dan N1DH

The audio system CANNOT be changed while connected. Nor can the audio device. This is by design.


Gotcha. That must have been changed since v1.5. I told you it was a PICNIC!

Thanks guys. Still puzzled that the BT mic works with the MAcBook mic test but not with Wfview. I’ll just keep on fooling around/learning.

Working super-duper in all other regards.

Dan N1DH


Just to be sure… when the radio is connected the Audio System goes BLANK. By the way, I can change audio in and out device selections when the radio is connected but I must disconnect/reconnect the radio to have those changes take effect…


Dan N1DH

Hi Dan.

It doesn’t go blank, it is disabled, as changing it while connected would be very bad!

The audio devices can be changed, but as you say, any changes you make are not reflected until you reconnect to the radio.


But mine DOES go blank! You cannot tell what Audio System is selected when connected to the radio …

Any thoughts?

Dan N1DH

Difficult to say, but it really isn’t a problem, just disconnect if you can’t remember which system is in use!

Most likely something on your display preferences, as this is what it ‘should’ look like:

Screenshot 2023-02-13 at 20.25.20


Your example’s Audio System FIELD looks blank to me. Is that what everyone sees when the radio is connected? Seems a bit strange that it contains nothing while the other audio fields display their selection, even though you CAN change them but changes don’t take effect until you disconnect and reconnect the radio.

You’re correct of course, that checking is simply accomplished by disconnecting the radio. But why isn’t that the case with the other audio fields that can’t really “change” either until disconnected?

Thanks again for your patience and kind help.

Dan N1DH

I can clearly read Qt Audio in there…

It is because changing the audio input/output can safely be done while the radio is connected, but changing the audio system would likely crash wfview.

Dan, it is greyed out, not blank.

you may perceive it differently but that’s how it is built.