Can not compile on Fedore 34

Can not compile on Fedora 34 due to:

/wfview/wfmain.cpp: In member function ‘void wfmain::setAudioDevicesUI()’:
…/wfview/wfmain.cpp:5839:59: error: ‘Pa_GetVersionInfo’ was not declared in this scope; did you mean ‘Pa_GetVersionText’?
5839 | qInfo(logAudio()) << "PortAudio version: " << Pa_GetVersionInfo()->versionText;
| ^~~~~~~~~~~~~~~~~
| Pa_GetVersionText
make: *** [Makefile:1043: wfmain.o] Error 1

Simply REM out that line makes it compile and seems to run.

Why compile ?:
Binary build does crash within few seconds:
Segmentation fault (core dumped)

Version 1.5
Build 7010148

That means that the version of Portaudio on your machine is too old and doesn’t contain Pa_GetVersionInfo(). It may have other issues but you should be able to safely comment it out.

Not sure why it crashes, there may be something in the log file /tmp/wfview-{datetime}.log

73 Phil M0VSE

There are no newer Portaudio package for F34

Prebuild binary:
1.2d did also not run…so I build that also

Ver 1.5
From log it seems it can not get data from IC-9700, using LAN method
It seems not to be a “REAL” crash…log shows “rigctld: closing rigctld”
Why it says Segmentation fault at the console prompt when it ends ?


the reason why a segfault happens is that we stopped buidling for distributions that are too old.
F34 is considered “OLD”

I am aware of this “overspeeding” of releases from the fedora people.
They do not fix problems but continue on with new releases containing years old bugs.
Considering strongly to shift to another distributions because this speeding has no meaning for users.
But has nothing to do with wfview…
Except that the wfview binary build 1.2d did also not run on a updated F34 before it was EOL.

I am fairly sure that wfview has not worked on F34 for sometime. Most likely one of the other libraries that we rely on is also too old? As F34 has been EOL since June, there has been little interest on our side to find the cause!

that’s true. @phil . Just like Redhat releases – fedora is somewhat limited to what you can do with older versions. Not much you can do about it unless you compile it yourself (or we statically compile the stuff).

The build system is opensuse 15.4 and 15.3 works too which is already almost out of support.

It seems that the binary build on F34 has been tested for a long time.
Back in sept 2021 version 1.2c did also not work.
Maybe no one use Fedora on pc x86_64 platform

I began to use wfview (1.2d) in febrary 2022 and compiled it my self


not many do, no. for me the fact that redhat is involved is enough not to even try it. also yum/dnf js a major no for me

however it does definitely does not mean it has its uses.

many people fancy debian and it’s offspring.

I am using opensuse because of it’s kde integration and extremely well testing of packages, regression testing as well as the fenomenal zypper and tooling around it. and not to forget the idea suse has about other distributions, whete redhat etc let us down.

anyways if 1.5 compiles, you’re all set - :slight_smile:

I am using KDE on fedora (Gnome is not me), if you have brand new HW (which I had a few years ago) Fedora is the way to go.
Right now I run a lot app’s/dist in separate virtual machines (Virtualbox) on high end HW.
Shifting between different distros is cumbersome because they all have there “specialties”…it is easier to “fight” the same problems :wink: