Can't connect to ICOM7100

I have an ICOM 7100. I am on Ubuntu 20.40 LTS. I installed the flatpak (Build fb65109 on May 19 2021). I can connect to the 7100 using CHIRP. However, wfview can’t connect to it. I tried the following with no success:

sudo chown $USER /dev/ttyUSB*
Select the serial device (/dev/ttyUSB0) manually
Set “Manual Radio CI-V Address” to 88 (it reported “Could not use provided CI-V address”)

The ICOM CI-V settings are:
Baud Rate: Auto
CI-V Address: Auto
CI-V Transceive: On
CI-V Output (for ANT): Off

Any suggestions?

Hi Tim.

Yes we have recently discovered a bug in the manual CI-V setting that won’t allow an address over 0x7f. This is fixed in the lan-alpha branch, together with some other code where we will slow down polling for certain rigs.

We should have a new build available once we have completed basic testing. You can manually edit the config file (as described in the manual) and set the CI-V address in there for now though.

73 Phil


I edited ~/.config/wfview/wfview.conf and set this (I only modified the RigCIVuInt value):

When I launch wfview, on the Settings tab it reports Manual Radio CI-V address as “58” and no connection to the radio is made.

Hi Tim,

You need to convert from hex to unsigned int. 0x88 = 136. Try changing the value to 136.

The next build we provide will have a box in the program for this purpose.

Make sure your radio has CI-V Transceive turned ON, and that you have it adjusted to the same baud rate in the preference file.

Let me know if that helps,

de W6EL

Thanks, Elliott. That worked.


Hi Tim,

Glad that worked. There is a lot of code coming up that will make operation with that rig a bit smoother. So keep an eye on the list, it’ll be out in a day or two.

de W6EL

That’s great to hear.

I have one more issue. I can’t get any audio on my PC. I have the Modulation Input and Data Mod Input both set to USB. For Audio Output and Audio Input I have them set to default. I tried every option one by one on both of these.
I know my PC settings are correctly playing music on my PC speakers. What am I doing wrong? I am expecting to hear the radio audio output on my PC; is that a valid expectation?

Hi Tim,

Without using wfview, your rig’s USB audio is already present on the computer just like a USB sound card. You can select the USB audio source in fldigi or WSJT-X.

If you want to hear the audio coming out your PC speaker, then you’ll need to loop-back the audio, which can be done with virtual audio cables. The same can be said for using your PC microphone.

You might be wondering why then, are there audio controls in wfview. The answer is this: If you enable the built-in Server in wfview, then you need to select the rig’s audio ports so that when you connect a remote instance of wfview in, you can hear the audio. When you do this, you will, by default, hear the audio from the speaker of the remote wfview instance, and the microphone on that remote instance will be the transmit audio. Here is the chapter of the manual on remote operation.