Can't get a LAN connection - Linux install for a 7610

I finally got around to upgrading to Debian 11 on my laptop and hamshack (mintower) computers, and I installed wfview 1.1 on both as part of the upgrade.
On the laptop, I followed the standard Debian upgrade procedures from Debian 10 to 11. Wfview 1.1 (not 1.1a) installed Ok, but wfview drew a segmentation fault. wfview153 loaded Ok and had no trouble connecting to the IC-7610.
On the desktop, I did a clean install of Debian 11 (not an upgrade from 10). Wfview 1.1 installed Ok, but again wfview drew a segmentation fault. wfview153 loaded but will not connect to the 7610.
What should I look for?
…Rich W2RG

re the segfaults: if it does “use the other version” like you did. It has to do with the two builds that are incompatible with each others environment. (else everyone needs to build themselves with additional stuff installed which is not a good thing security-wise)

re connection to the 7610 – can you ping the rig? This to me looks like an network issue so be sure you are in the same segment covered by the netmask.

Also be aware that we are at 1.2c (a testversion – 1.2 is imminent) so consider using the latest. Basically any alpha/beta/whatever version is generally as good as the “official” version. Only the additional parts may be shoddy.

You hit the nail on the head in recommending the ping, Roeland.

I had pinged (successfully) from the laptop - and connected from the laptop - just before changing to work on the desktop. So I expected no problems. But something changed in the 7610. I could not ping from either the laptop or desktop or another computer on the LAN. So I cycled the 7610 OFF and ON, and ping worked again.

But I still can’t connect. I’ll check the netmask settings next.

I thought I’d be assured of a more-trouble-free install by using v1.1, but I’ll take your advice and move ahead to 1.2c.

TNX 73

… Rich W2RG

theer is no change in networking code between 1.0 / 1.1 / 1.2x so I assume it’s a local issue.

there is no firewall that happens to block UDP that you know if?

are there obvious differences between the ip address setups? Like different ranges, different gateways etc?

No, there is no firewall that I know of on any machines within the LAN. SO, unless bullseye secretly installed a firewall on the desktop and laptop, there is none.

The ip addresses are set by the same interfaces files that I was using under buster (Debian 10). Here’s what’s on the desktop:

you missed the paste :slight_smile:

The paste was there! And several other lines. Here are the missing lines (from my Sent file:

source /etc/network/interfaces.d/*

The loopback network interface

auto lo
iface lo inet loopback

auto enp3s0

iface enp3s0 inet static

I’m very curious as to why the 7610 stopped responding to pings. That behavior hasn’t recurred yet, but why did it happen at all?

I installed v1.2c yesterday and got a somewhat different behavior: wfview153 loads and connects but has no audio. On startup, it returns only one error message:


Unable to set stylesheet, file not found

Tried to load: [/usr/local/share/wfview/qdarkstyle/style.qss]


But there is no directory named /usr/local/share/wfview,

and qdarkstyle is in /usr/share/wfview


… Rich W2RG

I did a little fiddling just now, and I have audio again!
Still no qdarkstyle (of course), and now no spectrum or waterfall.
I remember there being some postings about that a while back, so I’ll try to find those and read them.

Roeland! After much more fiddling (this time taking notes as I went along), things are working on the desktop!

I still don’t have the qdark stylesheet, but all the wfview functions seem to be working (audio, spectrum, waterfall, multiple meters, etc.)

The key quetion now is: will it still be working in the morning? :wink:

73 … Rich W2RG

wfview 1.2c is now working properly on both my laptop and desktop.

Thank you, Roeland, for your help and your patience.

I think most of the problems that I had stemmed from trying to work on two machines almost at the same time - and, in the beginning, with different versions of wfview on each machine. I can’t make a rigorous case for that guess, though.

73 and TNX

… Rich W2RG