Can't get audio loopback devices to create?

Trying to install the audio loopback devices on Raspberry Pi 400 running the latest Raspberry Pi OS “bullseye”. Followed the instructions, and can’t seem to get the loopback devices created or initialized or something.

On boot, I get the error:
snd_aloop snd_aloop.0: cannot find the slot for index 10 (range 0-0) error: -19
snd_aloop snd_aloop.1: cannot find the slot for index 11 (range 0-0) error: -19
aloop: No loopback enabled

I thought perhaps there was a conflict with the existing hdmi sound card (I have a television as a display), so I also tried calling it snd-card-2 instead of snd-card-0 for the alias:
alias snd-card-2 snd-aloop
options snd-aloop enable=1,1 index=10,11

(as shown in the documentation).

k0in@raspberrypi:/ $ sudo modprobe snd-aloop
modprobe: ERROR: could not insert ‘snd_aloop’: No such device
k0in@raspberrypi:/ $ cat /proc/asound/cards
0 [vc4hdmi0 ]: vc4-hdmi - vc4-hdmi-0
vc4-hdmi-0
1 [vc4hdmi1 ]: vc4-hdmi - vc4-hdmi-1
vc4-hdmi-1

Any wisdom would be appreciated.

I’ve solved this issue by using index=0,1 instead of index=10,11

Still working through other issues.

This is fun, right?

1 Like