Choppy audio on MacOS

Thank you for the great cross platform software!

I have it working quite well on a Windows laptop (wired or WiFi) but on my i7 iMac running Mojave 10.14.6 I have quite choppy audio. I am running over wired LAN and into in IC-7610.
Granted it is an older computer, but I can run wfview virtually in Windows on this computer, and the sound quality is fine.
Does anyone have any suggestions for troubleshooting this?

Also one feature request… remember what frequency it was on so when you change to another band and then back again, it will be on the last frequency. Maybe I have things setup wrong, but the ICom software does this.


Hi Gordon,

Does the situation improve if you increase the buffer (latency) size? Or is it choppy at any setting?

We’re working on that feature request, which is a Band Stacking Register (“BSR”) that is maintained in software. Right now, we just use the radio’s BSR, which apparently doesn’t get updated when VFO changes come from the software (this was a surprise to me). This also limits us to bands that the radio has a BSR for. Most if not all supported radios lack 4M, 60M and all the common broadcast bands. So there’s that reason alone to code up our own BSR.

Thanks, and glad you’re enjoying the software,

de W6EL

Hi Gordon.

It is possible that the ‘choppy’ audio is caused by wfview detecting that audio is taking too long to process and discarding the oldest audio samples. Once connected, try reducing the RX latency in wfview to the lowest setting and then gradually increase it until the audio improves. Simply increasing the RX Latency setting may also help.

I have been trying to come-up with an automatic way of doing this but the workaround above should work for now. This issue seems to be more apparent on MacOS but I have found that Qt 6.2 (which was recently released) seems to improve things and once one of our pre-requisite packages (QCustomPlot) fully supports Qt 6.2, I hope to start using it for the MacOS builds.

73 Phil M0VSE

Thanks for the suggestion and explanation on BSR.
I have tried changing the latency, and there is no difference about about 75ms.
I should have used a better word to describe my issue. it isn’t choppy (like when the latency setting is too low) it is more like ‘clicks/pops’ and fading (which can sometimes sound like choppiness to me).
The strange thing is that using the same computer and running WFVIEW in a Windows VM, it is fine.

I’ll keep messing with it and will try it on USB to see if that makes a difference.
For now I’ll enjoy it on my Windows laptop as it works just fine there.


If I drop the buffer below about 50ms it has lots of dropouts.
Maybe a better description of the issue is
that it sounds more like ‘clicks’ which cause
the audio to drop. Sorry for the poor explanation.
I should also have mentioned that I’m running 1.2c

I’ve noticed that when using CHROME and downloading while using the ANAN7000 the audio will at times get choppy. I think this is occurring because CHROME is a utility hog of both bandwidth and memory at times. Perhaps there is some swapping taking place. This effect is easily reproducible at my QTH. Using NVIDIA or AMD FIrePro 5000 video cards and i7 processor. The cure was not to use CHROME…:wink:


When downloading on chrome I noticed audio can be interrupted or browsing just depends on the amount of data being downloaded.

I use local > 200ms – what I do is monitor the logging and see the number of underruns that happen and adjust that accordingly. It’s not a mac though. It’s possible that there are large differences in needed buffering.

OK, some additional information.
When I use a bluetooth headset (w/mic), and output the audio to it, then the audio is great; no clicks/pops/choppiness…
However, it will NOT give me any audio to my bluetooth headphones if I select my bluetooth microphone.
Furthermore, while the audio is good, it messes with my ability to adjust the volume on it. sometimes the volume in WFVIEW works, sometimes not. Sometimes the keyboard volume control works, sometimes not. Same with the volume on the headset.
Not sure if this helps or confuses the issue.

I’d like to try the 1.2d beat or the master with enhanced audio, but I am not seeing the MAC build instructions anywhere. Can someone point me to them? I’m sure they are there, but I cannot find them.


Hi Gordon.

Building on Windows/MacOS is a much more involved process. We plan to release 1.2d binaries soon on those platforms.

73 Phil M0VSE

I’m experiencing this as well. I even tried the 1.2d version, same issue. Windows version is working fine.
Mac is a 2015 MBP i7, 16GB, Monterey

So get this. I took a USB headset, plugged it into my mac, and the audio was fine.
The audio is only choppy with the on-board sound card.

Now, it will break up if the computer is under load some, such as opening chrome, things like that, but if you minimize usage of the computer, it seems to run fine.