Compile of WFVIEW and WFSERVER on AARCH64

Hello all

I have been trying hard to compile WFSERVER first, but that doesnt compile on RPI4 neither i386 or armhf,armel, arm64…

I then tried to compile WFVIEW(.pro) made Makefile and usually get stuck on either rigctld, or moc_audio. CPU Util goes 100% and I had to drive to QTH to power cycle the RPI4b 8G RAM twice.

I never thought that g++ process would kill the machine’s running staate, but when make -j is executed, ssh will stop working and all get’s stuck.

I am no programmer so question to the team - is there a way to find out?
(Funny that if I go to debian repos and find a .deb for either aarch64 or armhf, I am able to get wfview packages going (if I manually install all dependencies).

73 Jiri OK2IT

PS - yep, still using daily WFVIEW on RPI3B amd IC7300 to sometimes run 80m local net.

Last issue I have is that from time to time RF seems to still get through to the USB Port and when there is short period , wfview just crashes and I had to VNC in and re-launch - hence WFSERVER attempt with a crontab.

Try running make without the -j. It will take a long time but this will limit it to compiling only one file at a time. Keep it cool and don’t open any additional programs.

Let us know how it goes.

de W6EL

My build method.

$ copy in
qmake …/wfview/
qmake …/wfview/
change to.

$ ./

If there are no problems with the dependencies, you can build it in about 20 minutes with RPI3 using SSH.

However, as eliggett explains, you need to ‘Keep it cool and don’t open any additional programs.’


1 Like

Hi all

i managed to compile without -j parameter. It did took a while and while doing so, ssh became stuck…but I left it overnight. So I do have BananaPiM5 with eMMC onboard running wfserver.

What I found out is that if I use parts of .conf from wfview, I wont be able to logon. Usernmae,pass incorrect. altough they work in wfview. Only default from initial .conf (user,password) work ok. Not a big deal, but maybe could be looked into?

My plan is ot run it as a service, with crontab checking if it is indeed running, and restarts if needed. That way no need to constantly check over VNC etc.

I like the idea of running VFVIEW and disable local waterfall to save resources, but still requires a X Windows etc. so Server seems logical. I am now trying to compile and move to little TP-Link WR841ND Router, which has got USB Port… That would be excellent to run that on router direct!

73 and thanks for help

Glad it worked!

My dad has been running wfview gui server for quite some time using one of those small SBCs. He has it auto-login to the gui and auto-start wfview on login. While the command-line wfserver is of course more efficient on resources, his SBC is dedicated for this purpose and it’s easier for him to check on if he needs to.

He’s using the Inovato Quadra, not exactly the fastest thing but working fine for using the 7300 remotely.

With the command line version, last I checked, cpu usage was under 10%!