Compiling 1.2e - main window size problem


I compiled:

Version 1.2d at 2022-01-22 with the script
Raspi4 - OS Buster - screen size 1440x900
Wfview window size OK fits nicely into the screen

Version 1.2e at 2022-01-16 with the script
Raspi4 - OS Buster - screen size 1440x900
Wfview window size is much larger - doesn’t fit into screen
it seems it is at least double in size

When starting the older 1.2d version the wfview window is still fiitting into the screen.

To verify the problem I compiled:
Version 1.2e at 2022-01-16 with the script
Virtual machine Debian OS Bullseye - xfce desktop - screen size 1440x900
Wfview window size OK fits nicely into the screen.

What could be the problem at the Raspi that the 1.2e version gets this hughe size?
I have to mention that I connect to the Raspi with AnyDesk, but all icons and other programms have normal size, just 1.2e is out of limit. I don’t remeber if at the older compiling time I was connected via AnyDeask or directly working with external monitor / keyboard /mouse. Could this give a problem?

Any ideas?

73 Michael

Hi Michael.

I haven’t seen this myself, but it is likely a consequence of adding support for High DPI displays. I had “assumed” that it would scale automatically for smaller displays, but obviously not!

I guess we will need to make it a configuration/command line option? In the meantime, commenting-out line 60 in main.cpp and then recompiling should return to the original behaviour?

// QCoreApplication::setAttribute(Qt::AA_EnableHighDpiScaling);

73 Phil M0VSE

Thank you Phil for fast reply.

Yes that solved the problem.

I have an other raspi here with same OS (now I’m not at home, but in the garden) were I have all connected directly and will check if there is a difference in size to the AnyDesk connected one. If so, I will inform you.

73 Michael

Hi Phil,

compiling 1.2e on Raspi4 - OS Buster - directly connected to Full-HD Monitor via HDMI / Mouse/Keyboard via USB, with QT High DPI setting at line 60 in main.cpp.


Main window fills whole screen (1920x1050) and because of the menuebar (32x32) on top of the desktop, the buttons “About”, “Save Settings” etc. are not visible any more.
Had to shrink the main window vertical to get them, but it could not be done further, so the lower side of buttons is exactly out of lower boundary of screen. Horizontal Window ends inside the screen.

It means, that window doesn’t fit good on Full-HD screens, smaller screens are just cutting off the rest of main window. Seems this adaption function is only checking resolution in dpi’s but not taking into account the set screen size of desktop.

73 Michael

Hi Michael.

That sounds like you have scaling enabled as a Full HD screen (1920x1080) should be more than sufficient to view wfview.

I would recommend setting the appearance settings to large screen defaults:


73 Phil M0VSE

Hi Phil,

it doesn’t change wfview’s apearence, it uses in all 3 cases the whole screen.

The desktop as well the icons of programms are changing, but not wfview.
Do you like to connect via AnyDesk?

73 Michael

Hi Phil,
I did some reading concerning scaling. Let’s say I googled arround. Will recheck my settings because of headless configuration some parameters were fixed in the config.txt to let AnyDesk or other remote software to see a nice screen. Will let you know soon.
73 Michael

Hi Phil,
Problem is solved when using config.txt original version and hdmi display is connected.
Under appearence best result is medium screen for full hd display 1920x1080 px.

Problem still exists when trying to connect via AnyDesk and hdmi display is not connected => headless.
In this case AnyDesk reports no supported display or similar wording.
This was the reason I had to adapt the config.txt for the 1.2d version, what is now incombatible with the new QT parameter in 1.2e version.

Your wfview is ok on raspi4 compiling and working - my settings in config.txt for headless operation and remote control will make me loose some more of my white hairs. hihi

73 Michael

I have WFview 1.50 on a Lenovo 100e (ex.Chromebook) with Lubuntu 22.4 OS
and the screen did not show the lower part where Exit Program is.
I found that changing the original Font size from 11 to 10 made the buttons to be seen.
Now I have a cheap computer to run as a server or client
/ regards Tommy SM6NZB

yes, that’s nice too! Well I use a Rasbperry pi 4 as a server with Debian 64 bit and that works very well! Above all, it is nice and small and uses little space and power Vy 73 by Jan-Peter-DL3KVT

Jan-Peter, At my Remote site I use a Pi4 Raspbian with a metal case and a small fan inside.
The Virtual screen size is high but there is no actual screen attached, VNC is used to control programs and I have a Webswitch1216h to start the Pi and the rig remotely.
At home a 28/inch 4K screen so I can have the remote VNC session on a part of the screen
And ,my local Pi400 can use Raspbian or Win10-ARM.
/ regards Tommy