Compiling problem latest raspi os version

Hello,
I use succesfull wfview at my raspi 4 with a fresh install of Raspbian os based on Debian Buster. All compiles fine no fatal errors.
Trying the same at newest Raspbian os Bullseye from October gives a lot of dependency problems that I could not solve even when installing additional QT5 modules (because they are not included in the repository or I couldn`t find them, who is perfect?)
Has anyone tried it too? Or is it better to try an ubuntu based distribution at the Raspi?
Every hint is wellcome.
73,Michael

Hi Michael.

I haven’t tried wfview on ‘Bullseye’ yet. I will upgrade one of my Pi4s and let you know how I get on.

I suspect that the name of one (or more) libraries has changed?

73 Phil M0VSE

~WRD0001.jpg

Hi Phil and Michael,
I tried this also, it turned out that all dependencies could be met on Bullseye but one: qt5-default. It simply is not in the repo.
So I opted-out the line sudo apt-get -y install qt5-default || exit -1 by putting ### in front and then it installed. Although I could see quite some purple error messages passing in the terminal window. Now it runs but I found another oddity: My IC-R8600 mysteriously returns to the frequency 0.010002 MHz. This now happens also on my 64 bit Mint machine but there qt5-default is available.
Can I send some logs to you. Phil?
73, Peter - PA0PJE

OK, here’s more: It seems to work OK on my Mint 20.2 machine but the retune to 0.010002 happens only on the Rpi4 with Bullseye so I assume that the error messages running the script while omitting qt5-default causes this malfunction. BTW: The new bandwidth sliders work OK on the R-8600.
73 Peter, PA0PJE

Hi.

It does look like various packages have been renamed in “Bullseye” but wfview compiles and runs fine once the dependencies are met.

I did find that both the g++ compiler and Qt5 multimedia packages were removed by my Buster->Bullseye upgrade so I had to manually install them:

sudo apt-get install g++ qtmultimedia5-dev

As an aside, doing an “apt-get dist-upgrade” isn’t really recommended to upgrade major versions as Bullseye has upgraded (and incompatible) versions of almost everything but it worked for me (other than having to delete the .config directory from my home directory)

73 Phil M0VSE

Hi Phil,

I used a brand-new install of bullseye and then ran the script. I installed qtmultimedia5-dev by hand as well as all other dependencies in the list the only one I could not add was qt5-default. If I do sudo apt-get install g++ qtmultimedia5-dev it returns g++ (4:10.2.1+rpi1) and qtmultimedia5-dev (5.15.2-3) as already the newest versions. Leaving the qt5-default in sends the message as deprecated or probably available in another source.
73 Peter - PA0PJE

After a bit more playing, it appears that the recommendation to not do an upgrade is probably the correct course of action.

I think that I will wipe the SD card and write a new image as various things (other than wfview) don’t seem to work properly :slight_smile:

I will try to run the script one I have done this.

73 Phil

Hi.

Yes you are quite correct, the qt5-default package has been removed from Debian bullseye (and all other distributions which are Debian based).

This is because Qt4 has also been removed so there is no need for the qt?-default packages (which manages which version of Qt is default)

We will update the script so it doesn’t fail if qt5-default is missing.

73 Phil M0VSE

I had similar issues…of course I just noticed this post after creating my own…going to re-image with Buster and try again.

Jeff

Having the same issue on Ubuntu 21.10 with qt5-default. Thanks for this post, very helpful with troubleshooting the issue I was having. I will wait for M0VSE to update the script then try the installation again.

73

Hi All,

I’ve removed the qt5-default requirement. The script will still make an attempt to download it, but it will continue even if it isn’t found.

Let me know if it works,

–E
de W6EL

Hi Elliott,
On a fresh installed Rpi OS with latest version Bullseye the script runs OK now albeit I still have that on starting the program it now always detunes my receiver to 10.002 kHz regardless of on which QRG it was originally on… I have the impression that something is not working anymore. If I use wfview to tune to another frequency and then save the settings it still detunes to 10.002 kHz again only the previously selected mode is kept being used. On building I see all sorts of messages about deprecated declarations and versions. I can send you the output generated during the build in a txt-file. Is that OK?
73, Peter

Hi Peter.

The deprecated declarations are perfectly normal and can safely be ignored. This is because Bullseye uses a newer version of the compiler. We are currently testing code which will remove these warnings.

The de-tuning is something that I have never seen before and I can’t think of anything in wfview that would cause it. The only thing I can think of is that something is connecting to either the virtual serial port (or rigctld) and causing this. Maybe try rebooting the RPi and make sure no other ham programs are running before you start wfview?

73 Phil

Hi Phil,
OK, thanks for the explanation on these deprecations. The frequency jump does not happen on the 7610 or the 705, just the R8600 has this, and only in combination with Bullseye on the Pi. Rebooting the Pi does not change this. I even tried complete removal of wfview and a new install.
73 Peter

Hi Peter.

That is VERY strange!

Would you be able to run wfview in debug mode (wfview --debug) and then forward the /tmp/wfview.log file to me after connecting to the ICR8600 please?

Thanks

Phil

Thanks for the log Peter. It was quite revealing!

Basically there are various commands which are only relevant for rigs with transmit capability, and it looks like through some bizarre twist of fate, one of the commands was being completely mangled and was actually sending a valid command to copy RX frequency from a memory location on the radio!

These commands are now disabled for the ICR8600 so please can you try updating from master and let me know if this fixes it?

73 Phil M0VSE

Hi Phil,
I built a new one that works OK, now!
I add the debug file again, it’s much smaller now…wfview_new.log (36.8 KB)
If you want any more tests for the R8600 (and 7610+705) just let me know!
Cheers, Peter

Hello,

problem is resolved due to latest modifications of your source code.
See my reply to 1.2d release topic.

Thank you all for your replies .
Michael