Connecting IC-705 via WiFi to run WSJT-X on Mac

Hi, I have been trying to set up my IC-705 to work on FT8 using remote access via the built in WiFi access point on the radio and have problems with audio output.

My hardware is IC-705 and MacBook Pro running macOS Big Sur 11.6.2
Software is WFview 1.2 and WSJT-X Ver 2.5.3 and the Blackhole 2ch virtual audio driver from existential.

I have already used the WFview software successfully for normal phone i.e. FM, SSB etc. That of course does not use the installed Blackhole 2ch radio driver but rather the MacBook Pro built in audio.

The problem I have is when I use the Blackhole virtual driver it either does not work (no sound output) or it pulses and the audio breaks up.
Has anyone got this working with a Mac and what were the settings for the radio and WFview and what software was used?

Any help is appreciated.
Hamish
G0GLG

Hi Hamish,

I’m probably not the best person to answer you here, but I see that blackhole is a relatively new player in the loopback audio space. Have you thought about trying SoundFlower or Loopback? I know SF used to be quite good long ago.

–E
de W6EL

FWIW - when using SmartSDR software for Flexradio when running WSJT FT8 - there is a nag screen now that recommends Mac users use LoopBack to handle the audio properly. I’ve used it in the past on other audio projects and it’s quite a nice package and easy to use. It does mean you have to purchase it but I think they have a trial version.

Tom KB5RF

The pulsing might be because of the audio sampling - I experienced this a while ago and went into the midi control and changed it

Can’t recall the exact details - it was the subject of a thread and ultimately it worked fine on the Mac

Marc

G0GLG Hamish
7 January

Hi, I have been trying to set up my IC-705 to work on FT8 using remote access via the built in WiFi access point on the radio and have problems with audio output.

My hardware is IC-705 and MacBook Pro running macOS Big Sur 11.6.2
Software is WFview 1.2 and WSJT-X Ver 2.5.3 and the Blackhole 2ch virtual audio driver from existential.

I have already used the WFview software successfully for normal phone i.e. FM, SSB etc. That of course does not use the installed Blackhole 2ch radio driver but rather the MacBook Pro built in audio.

The problem I have is when I use the Blackhole virtual driver it either does not work (no sound output) or it pulses and the audio breaks up.
Has anyone got this working with a Mac and what were the settings for the radio and WFview and what software was used?

Any help is appreciated.
Hamish
G0GLG

Yes I mentioned it as a possible solution in this thread Clicks & pops on audio (IC-705) - #6 by gbine and I believe it worked?

73 Phil M0VSE

https://forum.wfview.org/t/connecting-ic-705-via-wifi-to-run-wsjt-x-on-mac/1217

This was the topic I think

Marc

phil Phil Taylor M0VSE
7 January

Yes I mentioned it as a possible solution in this thread Clicks & pops on audio (IC-705) - #6 by gbine and I believe it worked?

73 Phil M0VSE

Hi all,
Thank you for your replies, for now I have decided to bite the bullet and have decided to connect WSJT-X via USB.
As for phone I will continue to use trial using Wfview whilst sat at the computer, although I am having problems with the connection. The connection seems to drop out after around 3 to 4 minutes. I have tried both Station connected via built in WLAN and using my home WiFi router, it seems to be the same whichever method I use. If it persists and I can’t sort it I will be posting some more :slightly_frowning_face:

Hamish