Dark theme ..not dark

I have troubles with selecting the Dark theme

It changes theme but only to light grey, Bright theme is useless, white and light grey every thing.

The strange thing is that I have 1 install where it works
I have made 2 other installs…not working as expected

Linux Fedora 36/37 in Virtualbox’es Wfview 1.61, both my own build and the binary build downloaded from wfview.
Played with:
System theme ON/OFF, Dark/Bright, custom colors
Change OS’s theme settings

Have of course compared a lot to the one install which works


That one installs works as expected is not entirely true…
It can not shift to Bright Theme :wink:

@eliggett is the man on themes so hopefully he will reply, but the only thing that comes to mind, is you MUST have ‘Use System Theme’ unchecked, as this overrides the Theme and uses whatever the default for your O/S is.

73 Phil M0VSE

if you start wfview on the commandline, do you see an qdarkstyle error?

With the latest version, there is not a dark mode checkbox.

The selection is “Use System Theme”. When checked, it will use your system’s theme. When not checked, it will use the bundled theme (which is dark).

de W6EL

I expect that when system theme is unchecked it would be possible to choose dark/bright theme and colours. But I tried also with system theme marked

Yes it gives an error
“Unable to set stylesheet, file not found
Tried to load: [/usr/local/share/wfview/qdarkstyle/style.qss]”
Where it not is
Is in /usr/share/wfview/stylesheets/qdarkstyle/style.qss
Install.sh do that
If I move qdarkstyle to the missing path
It does not throws any errors but only grid and waterfall background changes to white, rest is still dark
Version 1.61 Build b373685by roeland…

Color scheme preset Dark, Bright, 2, 3, 4


Hi Knun,

Can you try using our build script to install? I’m thinking the stylesheet got misplaced.

de W6EL

I did use the install.sh
If you look inside install.sh it will place the files in /usr/share/wfview/stylesheets/



Not install.sh, the build script available at https://gitlab.com/eliggett/scripts/-/blob/master/fullbuild-wfview.sh

Before you do this, I recommend deleting any other wfview executables, as you may have ended-up with wfview installed in both /usr and /usr/local?

73 Phil M0VSE

Ah sorry just saw you are on Fedora. The build-script is only for Debian based.

If you have a /usr/share/wfview directory, try copying the entire directory to /usr/local (or visa versa)


1 Like

I have the stylesheets in both places, /usr/local… and /usr/share…

Now it works like this:
“Use system theme” unchecked
Shifting between “Bright” and “Dark” changes the spectrum, waterfall, freq and Meter colors. But entire window stay at either “bright” theme or “Dark theme” depending on “start” condition see below.

“Use system theme” checked
It seems that toggling between “Use system theme” checked/unchecked decides if the overall wfview theme is dark (system theme unchecked) or bright (system theme checked)
System theme is something like Light Grey)
The color scheme preset choice (Dark/Bright…) only changes some of the elements in wfview.
What ever cause this behaviour it is very confusing.
But one thing was wrong from begin:
Wfview is looking for styles in a different place as the install.sh script place the files


The color preset does not change all the UI elements. It is only for some of them. The default presets are just an idea for you to customize. They are in fact merely the presented color swatches on the screen, each with a color picker button and an HTML-style color code.

The “use system theme” button toggled wfview to either specify our own dark-ish theme or to use the system theme. This only is for the widgets, such as buttons, checkboxes, “blank areas” and so on. It is not for the plots, waterfall, s-meter, etc. this is because those elements are not generic elements that your operating system would provide color guidance for. They are custom to wfview.

I will update the user manual to make this more clear. Make sure to have a read over it if you have questions.

de W6EL

Hi Elliott

Thanks for your explanation.

I think the install.sh script copy the stylesheets stuff to a wrong place, at least in a Fedora setup which then leads to that the “system theme” bottom does not work as expected (as your describe)


Unfortunately each Linux distribution has ‘peculiarities’. Most of the scripts are written for Debian based distributions, so there will likely be manual steps required.

As far as I know, none of the core team routinely use Fedora, so if you can describe the steps required to get it working, we can add to the installation guide.

73 Phil

As described further above in the thread
[Fedora 37]
wfview looks for styles in [/usr/local/share/wfview/qdarkstyle/style.qss]
But install.sh copies it to [/usr/share/wfview/stylesheets/qdarkstyle/style.qss]

There are other issues with dependencies of other packages
Some of the libs are not in the same packages in Fedora as in Debian etc…
It can be handled if you are a little experienced with DNF/RPM DNFDRAGORA

I am willing to test (also future release) on Fedora and supply you with the necessary steps to get wfview running on Fedora.

You can either make a script or just give the description how to do

Ideal where if I could pack a rpm…but so experienced am not :wink:

1 Like

what you could do is make another section in INSTALL.md and have the requirements for your fedora version there.

on F34/35 (at the time that info was added) it was just a copy/paste of a few lines,
compile and install (*); starting from a click click next next finish setup from an iso
in a virtual machine.

if you have tested it you can add that to the INSTALL.md and make a PR.

I at some point will remove instructions of non-supported versions.

(*) hence no shell scripts

I will make stepwise install description for F36 based on prebuild binary.
I will start with F36 as prior to that wfview can not install prebuild binary and compile build not without some quirks.

that would be cool! And if you managed to make a PR, you could drop F34/35 as they are EOL too.

What do you mean by PR ?

I have just tested th F36 binary build install.

Attached the step/notes

F36-install-readme.txt (416 Bytes)


a Pull Request. Basically it’s a way to have your changes reviewed and merged.

So next time somebody gets the source code, it has your remarks added.
Thanks for your input! I merged it.