DX Cluster

So I’m using the latest Daily Build and trying to get the DZ Cluster working. So far no luck. What is it looking for in the Server Name field? I want to use wa9pie (hrd.wa9pie.net) for my cluster but no matter what I put in that field it will not let me get to any of the other fields.

So I figured out the TCP Cluster and it seems to be working fine.

Next question about the UPD connection. I assume it’s looking at the local host, 127.0.0.1?
My train of thought, if it hasn’t derailed, is that right now due to a heath issue I’m working remote and working ft8/ft4 only. Is it possible to get the UPD broadcast from JTDX, when JTDX is setup for multicast?
I’m also using Gridtracker, and sometimes JTAlert. I tried to connect wfview to the GT UDP Forwarding port but that didn’t work. Also tried to connect to the JTAlert udp forwarding without any luck either. Both GT and JTAlert forward to a port on the 127.0.0.1 local host.

Is there a way to connect to the cluster in Log4om?

Hallo Allon,
You must always close the entries with return!
Your entries for your DX -Cluster ar Follows…

Server-Name : hrd.wa9pie.net
Server -Port : 8000 !!!
Username : ( Ur Call!!)
Passwort : ****
Sport Time : 30 or longer…. Than Button of Enable!!!
Connect from Radio !!!
Thats all
Vy 73 de DL3KVT
De Jan-Peter

1 Like

and… don’tforget to save. (we’re aware of the return key vs click next entry field)

2 Likes

Like I said, I figured out the TCP connection. Haven’t been able to get the UDP connection working yet. I did finally get the TCP to connect with the Log4om internal cluster server. I assume the internal server gets it’s feed from the clusters I have setup in the Log4om configuration. Next trick is to figure out how to filter the data being fed to wfview do I can select band (or bands), and mode. I can do that within Log4om for the built in cluster but it apparently doesn’t effect the internal server. Headed over the the Log4om forum to see if anyone there has any ideas.
Great job on wfview guys, I love it, and I really like the direction it’s headed! Keep up the great work!

1 Like

Well, as I said, I wrote to you about your DX cluster via UDP, how to set it up. Just find it much less complicated and easier! Whether you can take over the filtering from Log4OM, I can’t say yet! Good luck and have a good start into the new week! Jan-Peter-DL3KVT

1 Like

The UDP connection was designed (and tested) with N1MM+ in mind, I haven’t tried ANY other programs so it may (or may not) work. It expects an XML string like the below, anything else will not work. It may be possible to adapt it for other formats though.

<?xml version="1.0" encoding="utf-8"?>
<spot>
    <app>N1MM</app>
    <StationName>CONTEST-PC</StationName>
    <dxcall>AL3CDE</dxcall>
    <frequency>7061.2</frequency>
    <spottercall>K2PO/7-#</spottercall>
    <timestamp>2O20-Ol-l7 17:19:37</timestamp>
    <action>add</action>
    <mode>CW</mode>
    <comment>CW 9 DB 18 WPM CQ AK </comment>
    <status>single mult</status>
    <statuslist>single mult</statuslist>
</spot>

73 Phil M0VSE

2 Likes

OK, thanks Phil! I’ll keep working with the upd connection and see what I can figure out. I use Log4om which has a Contest Mode built in so I’ve never needed a second logger just for contests.
I have gotten a connection between wfview and log4om via the TCP connection which seems to work well. The only think I’ve noticed is that if there are two, or more, stations on the same frequency it overlays the call signs on the spectrum one on top on the other.

Hi Alan, I would probably use the rigctld connection with Log4OM as it is more efficient and has a basic command cache which means the rig isn’t being ‘spammed’ with too many commands. This isn’t an issue with LAN connected rigs, but USB connections can become overwhelmed.

If you are using Log4OM 2, it is easy to configure, simply go to Connect/CAT/Show Cat Interface, and tick “Connect to active HAMLIB instance” make sure the port matches what’s configured in the wfview External Control tab, then restart wfview.

With the cluster, again assuming Log4OM 2, you can use the cluster server provided by Log4OM. Go to Connect/Telnet Cluster and select “Start Server”. This will start a cluster server listening on Port 23 (not 7300) “I think” that it only forwards spots that match the current filter rules but not sure on that!

I plan to add simple commands into the cluster client but there are other options available like the excellent CC User VE7CC DX Cluster which will de-dupe and filter spots and work as a ‘forwarding’ server for DX Cluster connections.

73 Phil M0VSE

1 Like

I’ve tried using rigctld several times and it works fine, but, for some reason every time I start log4om I have to go into the hamlib configuration and check the box that turns on the TCP Connection. It keeps getting turned off for some reason, I haven’t figured out why.

I do have the log4om cluster server turned on using port 23,and I can connect to that port from wfview using the tcp connection. Seems to work fine. It forwards all the spots, the log4om cluster filter apparently doesn’t effect the cluster server.

I had forgotten about the ve7cc software. I’ll install it and give it a try.

Thanks for the help!