Error in accessing data from WFview via rigctld emulation

Brief summary of problem (put in title as well): error getting data via Wfview with cloudlog-rigctl-interface
Radio Model: ICOM IC-7300
Connectivity (USB/Ethernet/Wifi/Other): USB/Ethernet
Operating System: Win10
wfview version (press “About”): 1.64
Checked the wfview manual (Y/N): Y
Checked the wfview FAQ (Y/N): Y
Tried to google it (Y/N/NA): Y

What I did:
Starting GitHub - Manawyrm/cloudlog-rigctl-interface: Connects Cloudlog to rigctld / hamlib via PHP on my server with ip, ending on 135.
Starting WFView.exe on PC with ip ending on 48, directly connected via USB to IC-7300. WfView works as expected. Enable RigCtld on Port 4533 (!) is activated
Expected behavior:
cloudlog-rigtcl-interface receives data on Frequency, Mode, Passband…
Observed behavior:
Undefined offset: 2 in /root/cloudlog-rigctl-interface/rigctld.php on line 68
data$ - Stream can’t be resolved by PHP-Skript. Analyzing the PHP-script it looks like WfView doesn’t deliver the data the same way rigctld does in its current version.

Thx for any ideas to solve the problem.

Hi Cornel,

Do you see anything interesting in the wfview log?

If there are some commands in rigctld that we haven’t implemented yet, it would help if we could see what they are. I think wfview will log anything it receives over rigctld that it doesn’t recognize.

de W6EL

hi E,
thanks for your reply. I neither have an idea, what commands shall be exchanged between die sh-Skript nor what commands fail. The log writes:

2023-08-14 11:19:21.527 INF rigctld: session connected: 2184
2023-08-14 11:19:21.528 INF rigctld: Unimplemented command “fm”
2023-08-14 11:19:36.224 INF udp.server: “::ffff:” : Received token request
2023-08-14 11:19:36.224 INF udp.server: “::ffff:” ( “Control” ): Sending Token response for type: 5

Last two lines occur in every case, i changed something on the 7300, QRG, Band etc.

Just saw, that script is generated in 2018, perhaps it’s outdatet, but there’s no newer version.

So this raises the problem again, how to implement the CAT-interface for using with cloudlog, because cloudlog doesn’t work on RigCtld data without an additional software.

‘fm’ is the command. Didn’t look up but might be a compound command, reading freq and mode instead of two separate commands

1 Like

Thankyou Roeland,
i didn’t see this change. I just put this changes to my files and IT WORKED for me.
Thanks a lot, now my CloudLog works with WFView :slight_smile:

1 Like