Error on change modes from rigctl (hamlib net)

Hi again
Happy New Year to all forum members

Well, I think I found a bug or a configuration error of mine.

I haven’t updated wfview in a while and now a few days ago I updated to version 1.55 and now I have a problem. Today I recompiled version 1.56 always using the script for linux /fullbuild-wfview and downloading all the code each time.

My setup that works great for a long time has the IC7300 and the ic705 connected via USB port.
After each instance of wfview active rigctld with two different ports
I connect the rigctld ports to the CQRlog program with net hamlib and until I updated to version 1.55 everything was fine.
If I clicked on a cluster indicator from the cqrlog, it put the radio on the correct frequency and mode. with both the icom 7300 and the 705.
Now yes that takes me to the frequency, but not the mode. if I’m in LSB at 7Mhz and I click on a signal on 20m, it switches to 20m, but in LSB.

I plugged the CQRlog directly into the USB port on the radio, and it works fine. I changed modes from wfview and it works fine.

It only happens if I pass the signal via wfview’s rigctld.
Happens with both the 705 and 7300 instance.

I don’t know if you can reproduce the problem. I imagine any other program we can connect via rigctld will also fail.

I haven’t updated the CQRlog for a long time, so I rule out that this application is the problem, but I don’t have another rigctl net client to see if it also fails.

I just have to try an older version of WFview, to see if it works well, but I don’t remember which version I was running before I installed 1.55, I’m sorry.

Greetings from Catalonia
73 Jordi

Adding a short video from my screen

Hi Jordi.

The best way to debug this is if you can click the log button and then enable ‘Debug’ this will show every command to/from the rig and to/from rigctl. If you then try the failing operation on CQRLOG a few times, you can click ‘send to termbin’ and paste the URL you receive here. We can then analyse the log.

73 Phil M0VSE

I think is there.
I change from CQRlog band to band many times.


Maybe helps a little.
Well, sorry again…
I think I already know what happened
The CQRLOG sends along with the mode the width of the filter, and I changed the filter from 2400 to 2800Hz
It seems that if I have such a wide filter it doesn’t handle the modulation type well
With a 2400Hz filter configured in the CQRlog, it sidebands correctly.
here you can see the difference

Thanks Jordi.

I can see that from the log. It shouldn’t matter what width is selected though so we will add this as a bug!

2023-01-12 23:26:48.394 DBG rigctld: 16 RX: "M LSB 2800"
2023-01-12 23:26:48.394 DBG rigctld: setting mode: VFO: "VFOA" 0 "LSB" passband 2800 command: "M LSB 2800"
2023-01-12 23:26:48.394 DBG rigctld: Got new value: 4 = 0

2023-01-12 23:26:50.395 DBG rigctld: 16 RX: "M USB 2800"
2023-01-12 23:26:50.395 DBG rigctld: setting mode: VFO: "VFOA" 1 "USB" passband 2800 command: "M USB 2800"
2023-01-12 23:26:50.396 DBG rigctld: Got new value: 5 = 0

many thanks, Phil

Sometimes I make eSSB :rofl:

Hi Jordi.

This one was annoying me, so I had a look this morning and I had made a silly error. The CI-V command to set the operating mode also sets which filter (FIL1/2/3) to use. I got the numbering wrong and was sending an invalid FIL if width was 2700 or over, which the rig was (quite rightly) rejecting, so the mode wasn’t being changed.

It is now correct in master so please pull that and rebuild. I have also set more sensible defaults of which filter to select for each individual mode.

73 Phil M0VSE

Hi Phil

It really works
now switch modes smoothly with 2800Hz bandwidth.
CQRlog limits the width to 3Khz, and it still works… I don’t know if it would work above that, since I can’t implement it.
Thank you so much!

73 Jordi