Fldigi portaudio error

I’m running wfview on Ubuntu, with an IC705. I’ve followed the audio config directions and I’ve got js8call rx and tx working over LAN, however when I try to connect to the sound card in fldigi ‘Loopback:PCM(hw:10/11,1)’ I get an error about port audio device not being available. I’m only running fldigi and I’ve already double checked the config files for the virtual drivers. Anyone have any experience with this?

Try opening fldigi first, so that it can set that sample rate for the loopback prior to wfview opening.

Just gave that a shot and it didn’t work. One thing I’ve noticed is when I use arecord-l to show my sound cards there’s two instances of the loopback 10/11. Is that normal?

I’m also using AP mode and from the reading I’ve done I’m seeing that might be a problem?

On my system:

$ arecord -l | grep Loopback
card 10: Loopback [Loopback], device 0: Loopback PCM [Loopback PCM]
card 10: Loopback [Loopback], device 1: Loopback PCM [Loopback PCM]
card 11: Loopback_1 [Loopback], device 0: Loopback PCM [Loopback PCM]
card 11: Loopback_1 [Loopback], device 1: Loopback PCM [Loopback PCM]

Basically every loopback has two contacts, like a clip lead with an alligator clip at each end.

AP mode is fine on the radio, it may limit your computer’s ability to get online at the same time but otherwise it’s ok. If wfview is connecting and controlling the radio fine otherwise, then it is not related to the loopback issue.

Here is my fldigi audio configuration:

Again, I have to make sure no programs are using the loopback and then open fldigi first. This way fldigi can set the “soundcard” parameters first. You may also want to click on those Capture and Playback menus and make sure the correct thing is selected (in case it changed names or something). Launching fldigi from the command-line might help identify issues. You can also try building a recent version of fldigi from source, it’s not too difficult and may help.

de W6EL

Also here is my wfview audio configuration:

Note my DEV=0 within wfview. For fldigi, I’ve selected the DEV=1 basically. This tells the thing what end of the loopback virtual cable to use. fldigi on one side, wfview on the other.

de W6EL

I see, after being a bit more patient starting fldigi first allowed it to connect to port audio. Same audio settings as you have. I’m running wfview with qtaudio, is that correct? Fldigi will connect to the loopback but I don’t have any audio. I’ve tried the controls on the wfview panel, just zero audio. I downloaded fldigi a couple months ago so I think it’s the most recent version, does building from source help anything beyond that?

Yeah I’ve got dev0 selected, I’ve followed the audio config to a t and double checked everything that’s mostly why I’m stumped. Wsjtx, js8call work with no issues

In wfview, you can try Qt, Port and RT. Use whichever seems to work best for your system.

Make use of the RX and TX Audio Metering within wfview (see our manual).

I followed your advice and built the newest fldigi from source. I was running a pretty old version. I also tried port audio, with the loopback 10/11,0 because that’s all that was available. Using the same settings you’ve got and starting fldigi first still ends with the same result, I turned on rx monitor and maxed out the volume as well. I checked to make sure the system isn’t using the usb card or loopback and no other programs are running. Is there anything else you might be able to recommend? I really appreciate your help so far

Finally got it! I had to use Portaudio, but what fldigi was hanging on was the sample rate. Default is 9600, I changed it to auto and kept the sample rate in wfview at 16000 and it’s finally feeding audio. Thank you! This makes the ic705 such a great little rig it’s amazing. Props to the devs

1 Like

Glad it worked out!

de W6EL