Getting Wfview to work with IC-756 Pro III

IC-756 Pro III and Wfview


I’ve been a Wfview user for about 8 months after buying my IC-7300. I find that your software does a nice job of bringing the radio onto my network, so that I can monitor the bands from anywhere in my home, and occasionally remotely. It is interfaced to a 2018 MacBook Pro Retina running Ventura.

I recently was fortunate to obtain an ICOM 756 Pro III transceiver in very good working order. Although I’ve been a Ham since 1964, I had let the hobby go dormant in the 1970’s until regaining interest last year. Because of that, even this ~20 year old radio is a bit of a learning curve to me, having previously only used HF rigs in the pre-solid state days.

Included with the radio was a Signalink USB sound card already configured to work with the IC-756. After some effort, I was able to get the pair working with my MacBook Pro using WSJT-X. However, keeping the Signalink consistently handling the transmit toggling was sometimes troublesome, so I purchased a separate CI-17 cable to handle the radio control functions. After a bit of trial and error, I got the combination of IC-756, Signalink, CI-17 and MacBook working WSJT-X perfectly. Here’s how the radio set-up page is configured to make WSJT-X work:

I’d like to get Wfview to work with the 756 running on the MacBook as well. I’ve tried a number different configurations, with the serial connection pointed at one or the other serial devices; one configuration seems to do nothing, the other causes Wfview to crash. I’ve tried implementing the CI-V function using a radio address of 6Eh. Nothing gets anything on Wfview to respond in any way other than the crashes.

I sure would appreciate some help / guidance.

Hector - W1AQP


Hi Hector,

Sorry for the late reply.

The 756 Pro III should work with wfview. The 756 Pro (I,II, and III) in particular is probably one of the first Icom radios to have a PTT CI-V command. I don’t own one but I think they are neat radios.

A few questions:

  1. You said “…serial connection pointed at one or the other serial devices”. Can you clarify? What serial devices? What are their names? Are any other serial devices connected to the computer?
  2. Can you verify that no other programs were open which might have been trying to use the serial device(s)? Close all programs down. Maybe even log out and back in.
  3. Verify that you have full permission for the serial port. This is usually not an issue on macOS but it is worth checking in the terminal.
  4. I would really like to see the log for the configuration and serial device that crashed. The little crash report there in the screenshot indicates, I think, that a qt library crashed which was being accessed within rigcommander. Getting the log file may be tricky since the program is crashing on you, but here are the steps to get it:

Drop to a terminal and run the following:

cd Applications
open --args --debug --logfile /tmp/wfview.log

When wfview opens, execute the usual steps to reproduce the crash. Try and not do anything else so that the log file isn’t too long. Then, send us the file /tmp/wfview.log. That folder is hidden by default in macOS, but you can go there from the macOS finder by using the Go menu and selecting “Go to Folder”. Type in “/tmp” and it will take you there.

Thanks for any information you can provide,

de W6EL

Hi Elliott,

Thanks for getting back to me.

Please disregard my comment about the serial devices. There was a 3rd USB device plugged into another port that was creating confusion; I removed it and restarted my Mac. That eliminated the confusion, but the crashing problem remained. I am now certain that my CT-17 cable is represented as device 145220 in MacOS. When I try to use it in wfview, as soon as I click “Connect Radio” within a second or 2, I get a crash.

I have checked the radio’s CI-V setup. CI-V Baud Rate is set at 19200; CI-V address is set at 6Eh, CI-V Transceive is set to ON, and CI-V with IC-731 is set to OFF. That all seems correct to me.

I’ve tried capturing the log file per your instructions, but I’m struggling a bit. Haven’t worked with a command line interface since selling my Amiga in 1990, so Terminal is sometimes confusing to me!

When I open a Terminal window, I am taken to my user directory. If I type “cd Applications”, I get a “file or folder does not exist” error message. It seems my installation of MacOS Ventura was configured to only have an Applications folder in the root directory.

I tried “cd ~”, then “cd Applications”. I then entered your wfview command and wfview started, then crashed, but when I use Finder / Go to, it wants to take me to private/tmp, which does not contain the wfview log file. Even if I go to the root directory and do a search, I cannot find the desired log file anywhere on the MacintoshHD drive.


I did try something else this morning. This Mac has Boot Camp installed with Windows 10. So I booted up Windows and downloaded and installed wfview 64-bit on the machine. I get a very similar crash when I try to run wfview using COM6. Here is the log from the Windows version:

wfview-20231204094248.log (5.0 KB)

Here is a text file with the contents of an Apple crash report of wfview:

wfview crash report text.txt (49.6 KB)

Sorry, meant “cd /Applications”.

You have to change to the directory where is.

Still can’t seem to get that log file. I did try a couple of older versions of the Mac app. V1.6 also crashed, but V1.5 worked! I am using that for now.

When you go to /tmp, the finder may show it as something like /private/tmp. That is fine, just go with it and see if the log file is there.

Sorry if my responses are a bit hurried today. Quite busy.

de W6EL