Hamlib error with Wfview and Direwolf on Raspberry Pi

I’m running wfview on a raspberry pi along with direwolf and xastir for aprs on an IC-9700. Connection to the IC-9700 is via USB from the raspberry pi. Hamlib is used by direwolf for PTT. I’m using the virtual serial port in wfview for that, but I get this error in Direwolf:

Hamlib Error: rig_set_ptt command for channel 0 PTT
Protocol error
frame.c(355):icom_transaction return(-8)
icom.c(3826):icom_set_ptt return(-8)
rig.c(2755):rig_set_ptt return(-8)

Any suggestions?

Chris W6COV

Hi Chris,

You can enable rigctld emulation inside wfview.

Inside my direwolf config file I have this line:
PTT RIG 2 localhost:4532
That causes direwolf to use hamlib’s model “2” which is network control.

Within wfview, under Settings → External Control, check the “Enable RigCtld” option and be sure that the port listed in wfview matches the direwolf config file. Press Save Settings, and re-launch wfview (not sure if that’s 100% required but it can’t hurt).

In my experience, this works. What I cannot figure out how to do, is to get direwolf to use my loopback audio device for transmit. Do you have any tips on this? I’m using the loopback audio device because I connect to my 9700 over ethernet.

Here’s a little APRS how-to I wrote up, which it sounds like you are already way past, but may help someone else reading here:

de W6EL

Thanks! That worked. I’ll check out your APRS page.

Chris W6COV

For the audio part - right now I just have Direwolf doing usb audio directly into the IC-9700. My direwolf.conf file looks like this:

ADEVICE plughw:3,0

I’m reading through the wfview audio configuration pages now. To be honest, Linux audio has always confused me. It just seems 1 million times more complicated than necessary.

Chris W6COV

you definitely are not alone on this…