Hamlib error:

So now, for some reason, since I setup the wfview server and client I’m getting hamlib error from jtdx.

  1. Hamlib error: Communications bus error while getting VFO frequency.

  2. Communication timed out while getting current VFO frequency.

  3. Hamlib error: Command rejected by the rig while getting frequency.

  4. Hamlib error: Rig failure

  5. This error pops up at least once and hour or more.

  6. This one is fairly frequent also.

  7. This error is more intermittent than 1), maybe once or twice a day.

  8. I’ve only seen this error once.

My setup is a 7300, wfview, jrdx (or wxjt-x), GT, and log4om. Jtdx is connects via a VSPE pair of vitual ports. Log40m is connected via Hamlib port 4532.

The only way I’ve gotten these errors to stop is to turn off CI-V Transceive in the 7300. Problem with that is I lose the waterfall on the wfview client remote PC.

I can still see the waterfall in wfview if I connect to the radio (server) PC using Remote Desktop Connection and setup wfview to connect to the radio manually, just can’t see it on the remote (client) PC.

I don’t really need the waterfall if I’m working ft8 or ft4 since jtdx, or wsjt-x, has a waterfall, but it could be useful working ssb voice, although I guess I could just use sdrconsole.

Anyone have any other ideas?

Hi Alan.

Another option is to use wfview’s built-in rigctld server for JTDX as well. We are trying to move away from the VSPE solution as it makes it very difficult for wfview to control the rate that commands are sent to the radio.

73 Phil M0VSE

1 Like

Well I lied. I’m still getting the same errors after turning on CI-V Transceive in the 7300.
I also lied about not getting the waterfall on the wfview client pc, in wfview setting, if I turn on Manual Radio CI-V Address to 94 I get the waterfall but I’m still getting the errors. Back to the drawing board…

I thinks it’s all working now. JTDX was the culprit but thanks to Phil who suggested that I connect Jtdx via Hamlib instead of a virtual connection. I did that and also turned CI-V Transceive back on in the 7300. Everything seems to be running fine, no errors so far. Thanks Phil!!

1 Like