Having issues connecting an off network client

I am having trouble connecting my client on a different network to my host computer to view wfview. The only difference is the audio settings as far as I can tell. I have it on RT on my host, but my client has everything blank for RT.

This is the termbin link for the host : https://termbin.com/bb8i

This is for the client:

Any help would be greatly appreciated.

Here is an updated termbin file. It seems it’s trying to connect but I’m not entirely sure.


Should I have static routing enabled on my router?

Almost impossible to say without knowing your network layout.

If your two networks are connected together, then yes you would need to enable routing between your networks.

If your two networks have separate Internet connections, then you would need to enable port forwarding of UDP ports 50001-3 to your wfview server address on your router and then connect to the ‘external’ IP address of the router from your wfview client.

73 Phil

Looking at your log though, you are getting a VERY high number of lost packets. This usually indicates a less than perfect Internet connection. Streaming audio over UDP requires a very stable connection and some of the more inexpensive wifi devices are not capable of doing it reliably.

I would recommend following Remote Operation (server) | wfview exactly to ensure you have the client and server configured correctly.

I’ve got the packet issue sorted. My networks are combined. I tried to separate them but it just led to more issues. I’m not very savvy when it comes to technology but I’m sure I can navigate my way through it.

On my routers page it only allows for forwarding of 1 port. Maybe more? I’ll have to dig some more into that. I really appreciate your help. Happy Easter if you celebrate.

Here is the updated termbin file.


Any ideas? I’ve been racking my brain about this for days. I talked to tech support for my router and everything seems to be in order.

As said by Phil… If we do not know the network topology you use…

We also do not know things about most routers, ISPs etc.

and to answer your question…

you need to be able to forward all three UDP ports you use and you also must be sure your client doesn’t already use itform something else. (e.g. it needs to be free)

Thanks for the reply. All 3 ports are forwarded. How can I see if anything else are using the ports?

I’m hardly using indows but a quick google gave me this

(and that’s what I use in linux)

netstat provides statistics about all active connections so you can find out which computers or networks a PC is connected to . You can use the network tool for Windows, Linux, and macOS conveniently via the command line.

so I think windows has such a tool as well. Not sure. you could test it as well by moving to 50011/12/13
instead of 50001/2/3.

There are some “windows tools” that may use those ports as well iirc.

i changed all the protocols specifically to udp on all of the port forwarding settings. and When i do the netstat command i it doesnt show any active UDP ports, only TCP. even then, no TCP ports are using the 50001, 2, 3 ports.

Does my setup look okay to you?

my apologies already for you - since you asked - no. it doesn’t

the static routing towards the DNS does not make sense.
We asked for the network topology, not a few screenshots of a router we don’t even know, let alone start googling for a manual.
I don’t know what options you fed to netstat, I don’t know where you tried to run it.

the idea is actually pretty simple.

a) ditch the static routes towards DNS. Just have the queries go to the outside world without having a rouer intervene, which actually iytse;f knows better how and where to route the queries to.

b) make it like this, assuming you use the standard ports:

internet -----> router udp open 50001/50002/50003 towards the device that has the ports open.

If that is a rig, use the rig’s ip address
if it’s a pc tha runs wfview in server mode, connected to a rig over USB, take that IP address.


UDP 50061-50063 IC-705 ( 50061-50063
UDP 50021-50023 IC-9700 ( 50021-50023
UDP 50011-50013 taplopwired ( 50011-50013

no translations, no port triggers etc. and if that works, you can always consider adding security
measures; test each change if it works etc.

And again DO NOT USE STATIC ROUTING especially not for stuff that’s on the internet. Unless you
like creating issues.

Not a problem! I realize everyone has lives outside of this. I appreciate any help I can get. Im not very tech savvy so I’m trying my best.

Okay so I ditched the static routing. I have the 3 forwarding ports setup like in the second picture. The device ip address in the picture is the server computer connected to my 7300. My server computer isn’t finding any UDP ports when I use the net stat command.

My log shows “setting rig state for wfmain” and that’s the last of it and won’t connect. All the ports seem to be okay.

The client log states it is waiting?

The server log does or does not show the incoming connection?

So I’m an idiot. The ip address I’ve been trying to use is not the right ip address. It’s my computers ip not my public ip to access off the network. Secondly because I have StarLink my public ip is different than my routers IP. I thought adding a second router and disabling my StarLink router would fix that issue but it seems to not have. It’s rather frustrating. So I’m trying to get that sorted.