Headless server setup

I’ve read a few posts on this subject, but could use some help. Trying to set up a Raspberry Pi 4 as a headless server for Wfview. I plan to access over wlan and internet with a Surface Pro 8 running WSJTX/JTDX, etc.

I’ve written a new image to the SD card based on Debian/Bullseye using the Raspberry Pi Imager on a known working Raspberry Pi 4. I noticed that when running the Wfview install script that qt5-default is not included in Bullseye. I managed to get it installed and wfview appeared to build successfully.

However, when I try to run Wfview from the CLI, I get the following response:

pi@raspberrypi:~/Downloads $ wfview -h
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.


I think I will try re-imaging the SD card with Buster and try again…


Hi Jeff.

wfview does not currently run in ‘headless’ mode, we have plans for a server only version but at the moment you still need a gui. The easiest option is to connect to the pi via VNC.

73 Phil M0VSE

I managed to get the HDMI output working long enough to get the basic configuration done. (I didn’t realize HDMI was so problematic with Raspberrys.) VNC is a good idea.


I’ve never had a problem with HDMI on my RPis… What I usually do in this situation though is to manually enable sshd by creating a file called ssh in the root of the SD card after I have written the Pi image.

Once it has booted, you can then ssh to it and use rpi-config to enable the VNC Server.

73 Phil

You might need a “Dummy” HDMI plug you can get from Amazon to get graphics to start without a monitor connected.

This is my first time using an HDMI output on a Pi and it seems to be working for the moment, although I think I will stick with VNC in the future.

I understand the rationale for disabling SSH by default, but it is annoying to have to create the file, especially when I forget to do it!


Add these two lines to /boot/config.txt and reboot Raspbmc:


hdmi_force_hotplug=1 sets the Raspbmc to use HDMI mode even if no HDMI monitor is detected. hdmi_drive=2 sets the Raspbmc to normal HDMI mode (Sound will be sent if supported and enabled). Without this line, the Raspbmc would switch to DVI (with no audio) mode by default.

1 Like