Hotspot Connectivity

Wfview is working great on my LAN. I have opened ports 50001-50003 on my router. When I try to test an external Internet connection from Wfview on my macbook pro using my phone hotspot wi fi, Wfview won’t connect to the Wfview instance running on my minimac server in the shack connected to the LAN.

Any thoughts?

Make sure you are using your Internet providers IP address for your Internet router/modem.


Good call. I’ll try that out. Thanks.

Hi Steve,

We could use some more details.

Anyway, the usual issue is not forwarding the ports properly and/or a series of incorrect ip addresses. Check and re-check everything. Don’t forget that wfview uses UDP ports. Check your router’s port forwarding very carefully and verify your WAN ip address.

wfview will generally work fine once you get it all straightened out, many of us use our shacks remotely this way.

Hang in there,

de W6EL


Have you tried connecting directly to the radio from the remote connection? That’s what I do. You’ll probably have to disconnect the local wfview first; my 7610 only supports one connection at a time.

73 DE Peter N7MXK

Where does the WAN IP address go? In the server IP address location?

If so, how does Wfview find the radios IP?

Any screen shots would be helpful.

But I will hang in there. That’s why asked!


If you are coming in from outside your LAN, which is what I think you want to do, then your public IP (WAN) address goes in WFView’s Settings > Radio Access > Hostname.

Then you’ll need to port forward 50001, 50002, and 50002 to the radio’s IP. That’s how WFView knows how to get to your radio. You can get the radio’s IP from the radio’s internal menu (on my 7610 it’s in the Network menu as DHCP), or possibly from your router’s admin menu. At the radio’s Network menu you can also double-check that the Control, Serial, and Audio ports are all at their defaults of 50001, 50002, and 50003.

Hope that helps.

73 DE Peter N7MXK

Yes, trying to connect outside. Yes, this helps a lot. Now, I’ll see if I can do it! But much better prepared. Thanks

Got it!

It was the Broadband IP address that is needed on the client. Popped that into the radio access host name and away we go.

This has been a long time coming and thanks so much to the Wfview team and all the support.


Hey guys you don’t need a set up or any port forwarding stuff.

Just install FREE tailscale on all your devices and you have secure private IP access from and to all those devices from anywhere on the planet.

And unless you are stupid enough to give someone else your full setup and password no one will ever access it.



Very nice! Glad it’s working!

de W6EL

I would be hesitant to install something like that unless I really needed it. But to each his own.

also dismissing by “there is no need to set up any port forwarding” will get many people into trouble if they miss the tailscale stuff. And rest assured: we do not support that if any question arises.

Poeple easily can make a mess of it and our time is too constrained to give them a few basic CCNA things.

And at last “thinking you are safe” is not a good start.

Just to add to the knowledge base: adding the broadband IP address as host name works both on LAN and WAN. As pointed out, if the radio shuts off, Wfview can’t turn it back on unless it’s just sleeping. But I use RemotePC to login and get a remote screen. I start Wfview that way then the client syncs right up.

And all this is 100% Mac OS!

Thanks to the developer team!



Regarding the shutdown problem, you might find this menu setting helpful. It gives you a choice when you turn the radio off from the front panel by asking you want it to go into standby or fully off. Look for “Power OFF Setting (for Remote Control)” in the network menu.

Cheers and 73 DE Peter N7MXK

Using the WAN address on your kan generally works yes.
But if the router does not do triangle routing…