IC-705 PTT stuck ON

Disclaimer - New User (smile)

Problem: PTT sticks ON as soon as the command is issued, and the only way to disable is to restart WFView (I think), and/or wait for the TOT to timeout.

Configuration: IC-705 running v1.26. WFView v1.1 running on a Windows 10 Pro, v 21H1. Radio has a short 2m whip mounted to a base behind the radio (so the RF output is near the rig).

Conditions: Initially I had the rig next to the PC, but them dialed down the RF Output to zero and put it in the other room. Problem remains. I am using the default CV-I and port control addresses. Prior to attempting PTT, the radio controls all appear to work with very little latency from the rig to the laptop. (another frustration is that the repeater settings don’t appear to be “sticky” and will be different upon restarting the program) Once I hit PTT, the button switches to Receive but remains ineffective (the 705 continues to transmit), going to the settings tab shows the radio connected but sending the PTT Off command does not switch the radio back to Receive mode. Exiting the program and restarting it does not re-establish connection to the 705 even when clicking on the ‘Connect’ button on the settings tab. The radio itself appears to be back in local mode and PTT on the radio works find. Several attempts at closing and opening the program do not allow me to restore my connection to the radio. When I click “Connect” I see a message stating “Searching CI-V bus for connected radios”. If I power cycle the radio, it connects to WFView, but many (all) of the controls are inopp even though the radio now shows connected (including the Rx Latency data updating). By disconnecting and reconnecting WFView (and the ‘View’ tab) are finally back to fully operational.

Executive Summary: PTT locks up the 705 in xmit mode, and it must be power cycled and then WFView must be restarted AND then be disconnected/reconnected to restore control.

Any ideas as to what to check for or change?

Hi Craig.

Yes the repeater settings are not currently stored, this is something that we will address in a future version.

I have never seen this with my IC705 so it may be RF related as the antenna is so close to the radio? I assume that you are connecting over WiFi. Are you using a separate wireless access point or the IC705 in AP mode? I have found the AP mode to be quite unstable so always recommend an external AP and connect both the radio and your computer to this.

It is also worth trying the latest beta version available on the website as this contains numerous fixes.

On your final point, this generally means that the audio stream is established but wfview was unable to establish the CI-V stream (this can usually be seen as NONE in the bottom right hand corner of the window, rather than the radio model)

73 Phil M0VSE

Hmmm…same result with v1.2d so maybe it is the configuration or the fact I am using a local antenna on the 705 (even though I have Tx power at 0%). I had moved it to the other room, so it isn’t interference with the PC, but it may be interference with itself (RF). I will try an external antenna next. I do have it in AP mode with it logged into my local WiFi and I am accessing the radio through the router via WiFi from my PC.

For testing it was convenient to use 2m and an HT (rather than HF). I will try HF after I’ve solved the lock-up.

Meanwhile, any tips on remote operation using port forwarding when I am away from the rig (e.g. on the other side of the country)?



Hi Craig.

Sorry just to clarify, if you are logged-in to your local WiFi, the IC705 must be in “Station” mode, “Access Point” mode is where the IC705 creates it’s own WiFi network that your PC connects to (many users have found AP mode quite unstable.

73 Phil M0VSE

Hi Phil,
Yes, this is just a case of not using the right words. I do have my 705 in “Station Mode”. The confusing use of the terminology is because to connect to the WiFi, you have to go through the “AP” menu selection. My 705 is connected to my local WiFi and I have enabled the User ID and password information for the application to log into my 705. Although, now that you mention this - I think I might actually try AP mode with the 705 to see if the behavior is different. I haven’t (yet) tried connecting to an external (rooftop) antenna either - but plan to do that this weekend.