IC-7100 support for remote audio?

Is remote audio supported for the IC-7100?
Tnx de Arnie W8DU

Hi Arnie,

We’re working on it. We’ve found a few glitches with the “older” radios. You’re welcome to try it if you have the proper connections. You may find the controls a bit finicky.

Support for the IC-7100, used remotely, is planned for sure.

–Elliott
de W6EL

Thanks for the reply. I will be looking forward to updates on this.
73 de Arnie W8DU

Just trying this out for the first time. Installed on a WIN10 system and it appears to work fine. I then enabled the server setup, saved, exited and restarted.

Server system uses the defaults in the Server setup window
Remote system uses Connect over lan (server computer ip and user/password created in the server setup) info with radio control port 50004.

But, I am not able to connect remotely from the other WIN10 system.
Am I missing something?

Thanks

Hi dpdt,

Are you using an IC-7100 as the parent poster in this thread was? If not, what radio are you using?

What happens when you try to connect?

Thanks,

–E
de W6EL

Thanks for the response. Yes I am using a 7100.
Everything seems to be fine on the computer connected to the 7100. With that system running as a server, connecting to it from another computer also running wfview, I do not get a connection using port 50004. If I change it to 50001 I can hear the 7100 but cannot change anything. Is it possible to have total control from the remote computer?

Stay healthy.

I am a new user so I have reached my daily limit. But the bot suggested that I just edit a previous post, so here:

I used the default port settings. And the settings tab for the computer connected to the 7100 and successfully controlling it is:

The server setup for this computer is:
(Only 1 embedded for a new user)
Enable is checked, Control Port 50001, Civ Port 50002 Audio Port 50003 and then created a Full User.

The settings for the remote computer are:
Enable PTT is checked, virtual server port is none, connect over lan is checked, Port 50004 default (also tried 50001), and lower right corner has NONE

If I use port 50001 I can see the first tab and everything looks like that on the server image. I can hear but cannot control.

What have I messed up? Again, I have not issues so far with using wfview on the computer connected to the 7100 so all the 7100 VIC/USB settings are correct.

Stay healthy.

Did you change the port in both the server and the client? It must be changed in the server section on the machine that is operating as a server (then save settings and restart wfview.)

You need to also make sure that the chosen port (50004) is available.

One question, why are you changing the port? Is port 50001 already in use?

73 Phil M0VSE

To answer your other question, yes full remote control of the IC7100 should be possible, you will need to make sure that CI-V Transceive is ENABLED in the USB settings of the rig. Also make sure that CI-V USB Port is set to UNLINK.

I would recommend 19200 or 9600 baud as the IC7100 can struggle at higher speeds.

The Rig model should display in the bottom right hand side of the wfview window. If it says ‘NONE’ this means that your rig has not been properly detected and you will not be able to control it. The lack of CI-V Transceive is usually the cause of this.

73 Phil M0VSE

Phil,

I tried to reply yesterday but was limited to number of posts because of my new member status. I did edit my previous post to include better description of what I have done and how the system responds. Please look at that edited post.

For further clarification I am including an image of the server setup:
serversetup

and the remote client computer settings:

Summary: current server configuration works well. No issue so far controlling the 7100. The client does not make a full connection so it is unable to control 7100

Stay healthy

Hi.

As I mentioned in my other message, if you change the control port on the client, you must make the same change on the server settings page (otherwise how is the client going to be able to connect to it?) From the screenshots in your message you haven’t done this?

73 Phil M0VSE

Also, You are using a manual CI-V address, this is unlikely to work at the moment due to the way radio discovery is done. It is a MUCH better idea to enable CI-V Transceive in the radio and leave auto CI-V address enabled.

73 Phil

That was it. I changed CI-V Transceive to Yes on the 7100 and unchecked Manual on settings tab on server.

Thank you.

Stay healthy