IC-7300 Mic audio from Client to server missing?


Ive been trying to get Remote Mic audio to work on IC-7300, Using Windows on both sides.

I can receive audio and control everything ok remotely. Only thing is missing mic Audio.

Although i cannot get any audio device to show up with QTAudio on server side. No Icoms USB Codec , Nothing. When using Portaudio, i can select USB Audio codec from the list. So i cannot test with the recommended Qtaudio with windows.

Any ideas? Thanks.

did you install the icom drivers first?

Try enabling the DATA mode. That should let the xmit audio come from the USB codac rather than from the mike.

Data mode won’t help. Wfview on the server side needs to see the audio device. If it can’t see the audio device, then nothing will work. Roeland suggested making sure the drivers were installed for this reason.

Once the usb audio device shows up as a possibility, then set the TX Audio Mod source to USB. wfview has a menu for that under Settings on the Radio Settings page. Yes, the data modes are often already set for USB audio. But you can set any mode to use USB audio.

de W6EL


Same exact problem I have been having as Patrick. I have had no success with TX audio. I have been playing around with no success. Also, on the RX audio I have to set the client to PORT audio, with QT setting no RX audio. Atleast, I can receive audio with PORT. Missing something fundamental. Any pointers…what ICOM drivers are we talking about?. Trying on an IC7300.

Aamir (NF9Z)

Hi Aamir,

Windows users need to install the drivers from Icom’s website. Mac and Linux users don’t. So, if you’re server is on Windows, may sure it has the latest drivers from Icom.

To get transmit audio working, you must select the icom audio USB device on the server as the transmit audio device. Save Settings, and then try connecting.

The client side must have a microphone connected and selected as the transmit audio source. You can use the TxAudio secondary meter function to verify that audio is getting in to wfview from the mic.

If you see audio, then head over to Settings and Radio Settings, and select “USB” as the audio source for transmit modulation.

Let us know how it goes.

de W6EL

(check if it’s compatible with your rig)

Hi Elliott,

I did install the new driver (CD-301501-004) from ICOM with no change in the behavior. Following are some of the highlights for your reference:

  • Use a windows 10 as server
  • Use a windows 7 pro as client
  • I have switched the two around with same results
  • I have also used a Raspberry PI-2+ as a server with the same results. Pretty much followed the Linux install and worked out of the shutes
  • The only way I can get RX audio on the client is if I set the ‘audio system’ in radio access as PortAudio. Server still set as QTaudio
  • I have not been able to send TX audio from client-to-server-to-radio. So no TX audio…
  • I have captured logs and settings which are attached in a zip file
  • There is an IC7300 folder with screen shots of the settings
  • Server folder with screen captures
  • Server folder with logs of connect to disconnect and one with QT audio setup
  • Client folder with screen captures
  • Client folder with logs of connect to disconnect and one with QT audio setup
  • Hopefully, you would gather the setup from the logs and may have some insights
  • What is ‘TxAudio secondary meter function’ in your last email?

I am sure I am doing something silly!. BTW, I also use RCForb and it has been pretty good. The only problem is no iOS app support. Let me know if you need any further information. Happy Holidays…

Aamir (NF9Z)

(Attachment WFview_debug_NF9Z_20221224.zip is missing)

Hi Elliott,

I sent a reply with a zip attachment with logs and stuff….it was rejected by your server. How can I send you this zip file?.
Aamir (NF9Z)

create the log and share the pastebin link…

I got the log in my inbox.

We do like the “Send to termbin” method, and using this increases visibility for everyone on the forum.

Here is my reply to Aamir:

Hi Aamir,

On the client, I see this error:

INF audio: Output No audio device was found.

This means the audio output device was not selected or somehow became invalid. You can fix this on the client by double-checking that under Settings on the Radio Access page, you have selected valid devices. You won’t hear a peep out of wfview until you have a valid audio output device. Check the log while you’re running on the client side for this message.

On the server, I see a lot of errors related to your network . It may be that there is a problem with your wifi. It has nothing to do with network speed and everything to do with how optimal your network is for streaming real-=time UDP data. This is the error message:

INF udp.server: “::ffff:” ( “Audio” ): Sending (multiple packet) retransmit of “0x1c3”

It’s normal to see one right when you start but it should not persist. I recommend you try using wired ethenet only at first, and once it works, introduce more variables with wifi. It’s just the best way to work out these problems one at a time.

The logs show version 1.50, however, we do have 1.53 available now for download in our weekly public builds. See our Downloads page.

de W6EL

I’ll also add that you can’t change audio devices with an active connection – you must disconnect first.

Also the note in the log about “libqt5multimedia” is not valid for windows and really isn’t accurate anyway. The error means you do not have a valid audio device selected or that no devices were found.

de W6EL

Hi Elliott,

I have now connected over LAN no wifi…I can connect between the two but no audio all ICOM drivers are in place. Logs follow:

Logs are shorter and QT audio settings. I am kind of lost at this point and really hate tying up your time and resources if this is something specific to my setup and really not worthy of the larger community or audience. Thanks for your efforts.

Aamir (NF9Z)

Hi Aamir,

Please update to version 1.53 on your server and client sides. Please make sure on the server to select the radio’s USB sound devices (it is not selected currently), and then to press “Save Settings”.

de W6EL

I have updated the latest from https://www.wfview.org/public_builds/wfview-master-20221219–03-00-01 and on LAN only:

No luck. Only way to RX audio is to select PortAudio, TX no audio. QT has no RX or TX audio. BTW using another windows 10 machine for client. I smell there is a driver issue. Although I have loaded the ICOM7300 driver, maybe it is not taking effect.
Aamir (NF9Z)

The reason why you have no TX audio is the server isn’t using the USB audio codec:

    2022-12-26 00:37:37.731 INF audio: Output audio handler starting: "Speaker/HP (Realtek High Defini"

You need to correct this in the server tab.

73 Phil M0VSE

I have installed them, had issue with wsjt-x before. I will try to reinstall them to see if it helps.

Here´s my log file. https://termbin.com/2l31

Is that your server? Your server is still not configured to use the 7300 USB audio device. You must try and select it under Radio Server.

I can´t select any device with Qtaudio in radioserver it seems. Shows only blank. I´m runnin Win7 x64

did you install the icom drivers?