IC-7300 remote use

I am using an IC-7300 and a win10 pc as server - and a MacBook Pro as client.
When I used the log file on the server to see what happened i recognized that using 50003 as the Radio Controll Port gave me control with the client. All except sound.
By default it seems that 50003 should be used for Audio. Why will not port 50001 work for my solution.
How do i solve this problem.

Thank you for your work with this product - it seems to be a great product.

Hi Pål,

The protocol really uses three ports, by default:
50001
50002
50003

Each port needs a solid connection, and the port numbers should not be “remapped”. I would leave the default ports as-is until you get it working, and then you could experiment with a different set.

As for audio, make sure that under the Settings tab in wfview, on the server end, you have the correct audio device selected for the radio. Both transmit and receive audio devices have to be selected. Once selected, press “Save Settings”, quit the copy of wfview running as the server, and re-open it. My guess is that will fix it since you were 2/3rd the way there already!

Please let us know how it goes.

–Elliott
de W6EL

Thanks for info. I have tried to follow your advice - but no luck. I made the MacBook Pro a server - the only choice I got was “USB Audio Codec” on both transmit and receive audio device. (this is on the server). I used an iMac as client. I used 50001-50003 as described in the manual. No luck I connection - but when I used 50003 as the port for radio Control I was able to control the rig from the client-but no audio. On the server at the lowest right corner the following tekst appears:
Server connections: Control:1 CI-V:1 Audio:0. green and blue ball and IC-7300. Both computers were in the same local LAN - and I was able to ping both ways. In an local LAN I presume that the firewall has no role. when I used 50001 as the radio control there were no connection at all. Hope for more advices.

Hi Pål

That sounds to me as if something else is listening on the wfview default port of 50001, the easiest way to tell (in the MacOS terminal of the server computer) is to use the command:

lsof -i:50001 -i:50002 -i:50003

If you run this command while wfview server is running, you should see something like this returned:

COMMAND   PID USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
wfview  89066 phil   33u  IPv6 0xb87b913c67c78bfb      0t0  UDP *:50001
wfview  89066 phil   36u  IPv6 0xb87b913c67c791db      0t0  UDP *:50002
wfview  89066 phil   37u  IPv6 0xb87b913c65aedbfb      0t0  UDP *:50003

If anything other than wfview is showing under the COMMAND heading then that is the process that is using that port. You can pick any port between 1025 and 65535 for wfview server, just use a different port for each connection type (control, civ and audio) and whatever ports you pick, check that nothing else is using them with the command above. You also need to change the default port in your wfview ‘client’ and the civ/audio ports will be automatically sent to the client.

73 Phil M0VSE

1 Like

Thanks - this solved my case - it was another apple applications using port 50001.
After changing this - I am now able to control my station via network.
Thanks a lot for very good help - I will now try to control it over internet.