IC-9700 Lan and MBP15" Retina OSX 10.14.6 Mojave

First Impressions about the App was fine. Much more likely than Icom-Soft.
My Test-Hardware: Macbook 15" Retina early 2013 /OSX Mojave 10.14.6 . → W-Lan-> timecapsule as accesspoint-> Lan-> 24 Port managed Nergear switch-> IC-9700 (DHCP setted to fixed IP on the Router).

After setup the IP-Adresse I could connect the 9700 and could see also the Bandscope.
After playing a while, I realized, that the App was hanging up.
Inbetween my “playwork” the App hangs several times and I got “no reaction” im the alt-cmd-esc-window. Also sometimes the connection to the radio goes “corrupt” and i have to restart the App. I also realized after startup the App, the connection sometime fails.

Next what i realized was that the 9700 could switch to tranceive, but not switch back to receive!
I have to go to the radio and switch transmit manually back to RX.

So I tried this connection with Icom-Soft BAT on a Win7-PC and it runs. (I was not shure, that my network-setup was OK)

Sorry for my bad description, but my english skills are not really good.

Addition: I found out, that i can transmit without the repeater function.
Also it was possible zu switch back an RX, the Button changed in each case.
If I use the Repeater shift - and CTCSS on 123hz, i can switch to transmit, but not on receive.
Also it was not possible to switch to RX with “control an R”. Only the manual button (transmit) on the 9700 give me RX back again.

Kind Regards,
André DC4ASK

Hi André,

Thank you for the feedback! I think we do need to look at the keystrokes on the mac build as it seems like a few are not working.

Have you tried the “PTT OFF” button under Settings? It is a dedicated button that will send the PTT OFF command to the radio, regardless of the state of wfview. I know that sometimes it can hang up thinking that it is receiving when it is actually transmitting.

The behavior of the “Transmit” button is not dependent upon the repeater setting or any other. What you’re seeing is some kind of missed command or command response.

Can you send me your log file next time you are running wfview and encounter this (or other) issue?

Thanks very much,

de W6EL

(Attachment wfview.log.zip is missing)

Hi Elliott,
well I tried also the “PTT Off Button” but without any reaction.
I actally play around with Wfview, because of my Apple. I have also an Win7, but generally I do not like Mickeysoft.
I tried to upload the log file, but it is too big.
I try to send it as answer to the received E-Mail.

Hi André,

What you can do, is close wfview, delete the log file, and then open wfview, reproduce the issue(s), and then close wfview. This will make a single, small log file that you can attach here or email to me.

I’m with you on mickeysoft :-). I hope we can get wfview working on lots of platforms and give people more choices in rig control software.



wfview.log (4,8 KB)

Well, something new today…
I did not use wfview for several days.
Today I had time to play with, but I never be able to connect the IC-9700.
Ich can hear Audio from the PC-Speakers, but I can´t take control of the TRX into the main screen.
I rebooted the Icom and also the Macbook several times, but nothing changed.
I had done a ping from the macbook to the 9700 IP and had a very fast response.

Any Idea what happens here?

André / DC4ASK

Hi Andre.

That is almost certainly because CI-V transceive is disabled on the radio. Getting Started | wfview

73 Phil M0VSE

Thanks Phil for your reply,
But now I am confused.
I did not change that setting after my first “play arounds”.
And I am sure, that I had switched it to “ON”, but it was disabled now.
I had also not made a reload of any settings from the SD card.
But the problems concerning with repeater function before stays on. Sometimes hang up the App, or TX keeps on til I switch the TRX back manually.
Or better explaned:
I had set the following settings into the repeater window:
Repeater Duplex → Dup -
Transmit tone only
Tone 123.
If I push the Transmit Button, the TRX switch to “Send” but it is noch possible to switch it back zu RX. Also not with the buttons in the Settings-menue.
So I have to go to the TRX and have to switch Send manually to RX. At that time, the remote funktion of the App is gone, no reactions anymore and I have to restart the App.

If I try it on a simplex frequence, it seams to work.
(while I write this sentence, I checked It again. Yes, I can transmit with modulation ,OK a bit timeshift but clear, and I can also switch back to receive.)

Sorry for my bad english…
But what I am doing wrong?

Regards, vy 73 de
André DC4ASK

The “Transmit” button, once presed, should read “Receive”. Try pressing it a second or third time.

There is also a button “PTT Off” under the “Settings” tab, which might work if the usual way does not work. You can also press “Control-R” to force receive.

Any luck?

de W6EL

Hello Elliott and thanks for reply.

I forgot to switch off the power supply and so I could test the “Power On” button.
Hey, it works! :wink:
But afterwards I had to push the “Connect” button several times, til I got a connection to the 9700. Before was no connection.

Concernig your question:
No, I had no luck…
If I use the “Repeater-Setup” and I set the Repeater settings als described already bevor,
the following problems occurs:
Pushing the With the “Transmit” button, the TRX switch to TX… so far, so good.
With the “Transmit” button again, I can not switch back to RX.
I “pushed” the button several times.
Also not with “Control-R” or with “PTT-Off” into the settings menue.
My impression is, the App is hanging then.
I have to restart the App after I had switched the TRX manually to RX.

If I do not use the “Repeater-Setup” and transmit just simplex ( I tried it on 2m with a handheld as Monitor) I can hear me back and I can also use the “Transmit” button to switch back to RX by just push the “Transmit” button one times.
Also then it is possible to use the buttons into the settings page.

I have a little bit time lag with the modulation, but the quality was good so far. I think the time lag comes from my w-lan-setup.
Mac-> w-lan to time capsule-> managed switch from Netgear-> IC-9700.
I have had used a jabra headset for that test.

73 de
André / DC4ASK

Hi André,

That remote power on trick is really cool, isn’t it? I’m always surprised that it works.

There is a programmed 3-second delay after you press power-on before any commands will really do anything, FYI.

With regards to your bug, I really don’t know! I can say that pressing Connect more than once should not be needed. If you’re in that situation, I would press “Save Settings” and then quit and re-launch wfview. This makes sure you get a clean exit and clean start. Upon startup, it will try and connect automatically.

Can you send me a log file? Here is how to get the log file. If the file is too big, you may need to delete the log file (to clear it out), and then launch wfview, re-create the error, and then send that log file. We might also need a debug-level log file, but let’s do that after we try this step first.

Thank you very much,

de W6EL

wfview.log (4,8 KB)
Hello Elliot,

I tried what you was asking fore…
First I deleted the old log file,
then I checked the settings into the Repeater Window.
After that I could re-create the Error, or failure.
If using Repeater, the Transceiver keeps sending.
Doesn’t matter which way I try to switch back to RX.
After the test, I tried to end the app, but it was not possible.
I had to close the App with “close direct” ofer the apple menu or right mouse click.
It ist often, that I have to close Wfview on that way. Sometimes the app ist hanging and into the “shut down directly-Window” (Apple sign on top, fourth position into the drop down menu) I get the message, that there ist no responding from the App.

Btw. The Tranceiver was in Standby (green LED was flashing) and I had to restart the Icom to get access to it.
The Power On / Power Off had no function.
I think that it is necessary to switch off the standby function into the transceiver settings.

Regards, vy 73
André / DC4ASK

Hi, I have the same issue here, when i use repeater option in WFview i have the same problem, it goes to transmit and can’t switch if off, only by pressing the transmit button on the ic-9700.
I use here macbook pro (2014) with big sur 11.4

In simplex mode it works okay it seems.

  1. Chris
1 Like

the rigs definitley need stby mode ON; else you cannot turn on the righ after a poweroff.

re the restarting of the rig – if wfview cannot close the connection cleanly, the rig will keep
the LAN “connected” – meaning that you cannot reconnect. Yes a restart wil help here to clean
but generally wayt a minute or two will clear the rig’s idea of being connected and you can try again.

I don’t have a mac so maybe Phil or Elliot can help you more here,


I just discovered that when I disable ‘virtual serial port’ setting (none) then the repeater function works properly with switching RX/TX !
(working here on a MacBook Pro with latest Big Sur OS and IC-9700 connected with LAN)

  1. Chris

thans for the feedback. Did you have any software talking to the virtual serial port?

No, i had nothing installed using it, it was set by accident :wink:

I already made several QSO’s via repeaters, seems to work flawlessly now.

  1. Chris


We’ll have a look at it .

Same as me. I had also set a virtual serial port. I had try to play with other ham-soft on the apple.
After set to “None” the Repeater-Function seams OK. Just I found out, that a Frequenz like 439.0875 FM ist not storable. Every time I had done a “recall” I got 439.0870 (in USB?).
I got the message “stored on Place 1”.

Regards, André / DC4ASK