IC-9700 no spectrum + waterfall

I just downloaded wfview 1.64 and connected an IC-9700 via USB. Every function works ok but I have no spectrum + waterfall. The IC-9700 display says “145,750 and main”. The sub is off. What to do?

Please turn on CI-V Transceive on the radio. Make sure you have not checked “Manual Radio CI-V Address” and have not checked “Use CI-V Address as Model ID too”.

de W6EL

Hi Elliot
I have tried to help oz8zy…
Sound and other controls are working…
It looks exactly as when spectrum display on 9700 is set to SUB receiver then you get not spectrum/waterfall.
We have of course carefull checked that MAIN spectrum is selected on 9700
You have answered that earlier…wfview does not anything about the sub receiver

OS is WIN 10


Hi All`

I have also downloaded and run this program, reading about it it is fantastic

Now the problems, All I can get it too do is change the frequency nothing else works, Has anyone got a list off the setting for 9700 and the program. Would love to get it going.

Just checked my setting and now what was working does not.

Thanks in advance for any help

Mike G4NVT

Also unlink from remote and highest baudrate selected?

And you must have a good reason not to use ethernet?

I dont know if it was adressed at me…

Unlink have been tried, baud rate set to 115000

not using ethernet…
No…tried it quick without succes


There seems to be something strange …IC-9700 gives out 2 USB ports (3 including the audio port)
wfview connect to the wrong one, you need to manually to connect to the second of them.
tested on win7 and wfview 1.64

wfview doesn’t connect to the ‘wrong’ one, it has no way of knowing which port to connect to so the port MUST be selected manually. Have you looked at the manual as this is all covered there? Getting Started | wfview

No really, as I am not using WIN (Linux and LAN)…but in the quick I didn’t find a note about this in the “getting started” note.

I was just trying to reproduced oz8zy problem


Has tested a lot more.

Now I can reproduce the error from OZ8ZY.
Radio seems connected, freq control works etc. but no spectrum/waterfall and the freq axis show 1-5 not the freq from spectrum on 9700.
Wfview seems to be partly connected, log shows that and you can disconnect /reconnect by the connect bottom in wfview.
What triggers this situation is unclear,
To return to “normal”: exit wfview and turn 9700 off, really off at your power supply
await until USB has no power ( I am checking that in my Linux device info).
Turn 9700 on, start wfview.
What does NOT seems to have influence:
wfview: auto or selected USB interface, baud rate…+ a lot other things I have tested
wfview ver 1.61 or 1.64 Linux version
If USB B interface is filtered out. (wfview is running in Vbox environment and can decide which USB interfaces the vbox client shall see).
Observation: When the error accours at wfview startup, status from 9700 is some what wrong…wfview indicate LSB mode but radio shows FM…(reproduce able)
Indication that switching between LAN and USB connection in wfview without exiting wfview can trigger the situation…not solid confirmed.

Who the guilty is 9700 or wfview … ???

But it confirms my position on USB => UselesSBus :wink:

In my experience, using USB via a Virtual Box always presents problems, especially at USB speeds above glacial. Try running the entire system without using a virtual system. 73 John , UK

Virtualbox USB:
I can absolutely not confirm that, I have very good experience with that, some times it even works better than in WIN.

I run a lot my activites in vbox client, Linux special apps, WIN nessary apps etc.
Including a 300MB/s USB SSD…
But let that subject rest…we can have different experience due to HW/SW

But the OZ8ZY problem accours in WIN 10 native and I can reproduce the error

OZ8ZY has got LAN connection working…so we will forget about the flacky USB stuff.

I don’t blame wfview for it as I dont know where the problem is…I don’t like USB anyways

USB should be stable, as long as you install the Icom USB driver. The ‘default’ driver that Windows will use otherwise is very unreliable.

You may also find that a Windows Update will decide that the Microsoft driver is ‘better’ and replace the Icom one. If this happens, you should be able to re-install the Icom.

The majority of Icom USB issues on Windows are caused by the wrong driver being used!



And the second is not having the right settings of the rig.

Many pieces of software reset some settings.

Icom driver:
I dont know if OZ8ZY installed ICOM driver on his WIN machine, I dont think so.

But remember I saw the same thing in Linux.

But as a wrote…I dont blame WFVIEW because I dont know where failure is.

It run fine now on LAN and spectrum update is significantly faster on LAN


I had the latest ICOM driver installed.

OZ8ZY Jorgen