IC705 Not Correct

I have set up my IC705 per instructions for a Wireless lan connection, and I think I have set my radio up correctly, as it is recognized by my PC. However, when I launch the WFView menue an select Settings, and fill everything out that includes the radio settings, IE: IP address, Port, Username, Password, when I click on Connect, a notice appears at the bottom right of the settings page that says “Username or Password is not correct”

Note: I made sure my PC sees the radio with the correct Name I placed in the Radios settings and I clicked on Connect to activate the PC to link to the radio. It successfully disconnects from my Wifi connection and connects to the Radio. Note: if I miss this connection step, when I click on Connect in the WFview Settings page, the Message “Searching for CI-V bus for connected radios” momentarily appears ---- this appears due to the fact that I did not go back to my PC Internet connections and select the Radio. So, I got that right, but my only problem is that it does not recognize I have the correct user name and password. So what am I missing?

I’ve looked at everything on the radio, and in the PC and all looks good. What setting am I missing?

1 Like

Hi Tom.

Welcome to the forum. That is very strange. Are you using any non-alphanumeric characters in the username or password? If so try it with only a-z and 0-9. It is possible that we missed something with the encryption algorithm.

If this does fix it, I would be very interested to know what characters you are using!

73 Phil M0VSE

Hi Phil,
On the Icom 705 area where it calls for SSID (I’m assuming this is the Usernameaccording to manual) I used IC705 or tried changing it to Icom705 or used my call AB5ZJ). For Password I used lower case letters and numbers like tomsrig36, or IC705tomsrig.

None of those work - I still get “invalid user name/ password”

I must be missing something even though it seems simple to set up

Tom - AB5ZJ


That’s the problem. SSID is the name of the wireless network, there are two ways that the 705 can be used over WiFi:

  1. Connect both your computer and the IC-705 to an existing wireless access point (Station mode)
  2. Use the IC-705 in Access Point mode and connect your PC to that.

Without knowing your network setup, it is difficult to say which you are using.

The Username/Password configured in wfview is configured within Menu/Set/WLAN Set/Remote Settings in the IC-705 menu. Configure either Network User 1 or Network User 2 with the required username/password and you should then be able to connect to your radio.




you need to have the IC705 join your wireless networking at home. If it does not join, it won’t be accessible for a start. Can you check this?

Very good, Thanks, Phil,

I’ll give that a try. One thing is confusing in the 705 manual is it implies not to use Station ——- and I did view someone’s YouTube video and the way I have it set up comes from the way his video shows. So, there was confusion in setting up the Icom 705.

Perhaps you can add a notation about this setup method on your web page.
I’ll try this first thing this morning when I get to the ham shack.

Tom - AB5ZJ

Hello Tom,

Your post, and Phil’s tip, led to my discovery of Wfview yesterday, after spending hours trying to configure Icom’s RS-BA1 Version 2. Sorry for this long post but it may help someone else trying to configure either of these applications with the IC-705.

I have been trying to connect directly by wireless to the Icom IC-705 Access Point (PC<->Radio) with no success, but the USB connection worked fine on 3 different computers.

The goal was to get a Microsoft Surface Go 2 working with the IC-705, as described in multiple posts by Julian OH8STN, easily located on Google.

Check that your firmware is up to date for the IC-705 from Japan’s ICOM site, currently this is v.1.26, and that the RS-BA1 version 2 is updated.

The update for the RS-BA1 version 2 is here, not with the rest of the IC-705 firmware updates.

Here are the configuration steps for wireless operation of the IC-705:

MENU → Set → [p.3/3] WLAN Set → Toggle WLAN OFF [so password can be reset, if necessary] → Choose Connection Type [same page, one entry down] and Select Access Point (Connect to Phone, PC) [not STATION] → EXIT back a page with button or return key;

Select Network Name and enter what you want to use [suggest Call Sign, as it only accepts upper case], save it by using the ENT key of the on-screen keyboard → EXIT back a page with button or return key → and move up one item to

CONNECTION SETTINGS (ACCESS POINT) → that takes you to the Password entry section, it is case-sensitive and accepts characters like “-” but nowhere does it seem to define necessary password length or acceptable/unacceptable characters.

The Icom instructions could benefit from clarifying points to consider when entering Network Name, UserID, and password, and any special requirements.

When I was getting repeated UserID or Password incorrect error messages we looked at trying a simpler password, containing no special characters.

That did not fix it. I was working on configuring the UserID and password within the ICOM Remote Utility and not realizing that the Network Name was different from my UserID and configured from a less visible place in the IC-705 MENU structure.

My efforts led to multiple instances of the IC-705 in the Radio List of the Remote Utility and the delete key was greyed out.

Greg helpfully advised me on how to do the registry correction by using the supplied “Recover_Setup_Utility.reg” which resets everything to factory default settings.
Don’t use the Recover_Setup_Rsba1_Control.reg but do use the Update.exe.

It will confusingly show the RS-BA1 Remote Control as v. 2.40 while the Remote Control remains at v. 2.20 making you think that the update was not completed.

Suggest leaving Network Radio Name as “IC-705”

Toggle WLAN back to ON.

Ensure that your laptop, or Surface Go 2, is using the Wi-Fi to connect to your Access Point [in my case named as call sign VE7WFP], and not to your home network’s SSID.

Double click on the Desktop icon for the Icom Remote Utility.

It may open on the Radio List tab and show “offline”

If so, move to the Server List tab and click on the entry to turn it into a blue background.

Connect with the button lower-right on the screen. It should show “connected” under your Network Name.

[If it does not, check that ACCESS WLAN is turned ON and that your Wi-Fi connection is to the radio’s SSID, not to your home network router’s SSID.]

Also check Radio List settings are <> , if not, verify settings with a button on the lower left.

Double click on ICOM RS-BA1 Remote Control Software desktop icon and click on the Connect button (top left).

If the connection fails, turn it off so that you can use Connect Set (one to the left of top right button) to confirm configuration settings.

It is working now on a Microsoft Surface Go 2

BTW, Using the Connection Type setting in WLAN of Access Point you do not have to set your PC’s IP address to something in the 192.168.59.x range in order to connect. The radio had an IP address of and eventually connected without needing to change the IP address or Subnet settings.

If the Connection Type is set to Station then the radio gets an IP address from your DHCP (if DHCP is selected), or the static IP address that you assigned to the radio.

Hope this is of help to others.
What helped me was to discovers Wfview, this very helpful website, and that it only took a few minutes to install and have Wfview functioning. I am looking forward to learning more.

73 de Ian VE7WFP / VA7IGI Victoria, BC Canada

1 Like