IC7300 - RX audio to Client OK, but NO TX Mic from Client

Hell Code wizards, Before i have decided to post here, i assure you ive exhausted 2 solid days on attempting to locate what is wrong. Hardware is as follows
IC7300 via USB to Pi3 B+ SERVER - using Wifi to local WLAN
Client is WIN10 Laptop on WLAN
Issue is I have NO MIC audio being sent to Client as such …BUT at the Client, I have Rig control , and RX Audio - the sound is excellent thankyou btw.
Log files to be attached here from Client and Server .
It have been difficult to assitain if the issue arises at the Server or at the Client. I have doube checked the 7300 Mic mod setting and DATA OFF MOD = USB . I have also got DATA MOD = USB for future Digital program etc.
I have tried for a day to isolate the issue if it is related to the Pi3 ( server ) connected by USB and tryng to double check the audio system selection for the Pi3 USB hardware . Unfortunately , the USB connected PC or Pi etc when not using SERVER MODE , does not pass Audio in a single installion via USB tether. - Luckily i saw a post about this, and stopped late last night going grey.
On my Win10 client , wether i use plugged and select Headset mode …or no headset and use onboard mic , the 7300 does not seem to receive any audio frommy Client Mic setup.
It is very hard to determine if the issue is in the client or the server .
For the Pi3 server , i have downloaded and compiled several times and studied the live terminal data displayed - and i do see some sort of possible audio related error in pink writing …maybe about size of data array etc …

Im running Bulls-eye on the Pi3 , the only thing i can do lastly and reluctantly is do a full reimage of the Pi3 and start again - but this could be wasted effort if the issue is at the Client with Win10pro.
Hopefully the Log will tell you. Meanwhie i will start looking at saving my Pi3 image to HDD so i can rebuild tommorrow night.
I read and reread the manuals and install stuff . The connection itself and port forwarding for external WAN is a piece of cake, but i have the same issue on LAN or WAN for the client. You would swear that the 7300 had USB mod = 0 or DATA OFF MOD = Mic or ACC etc … But I have DATA OFF MOD = USB… but still no go .

Cheers Stu ZL2XC
Wfview radio settings etc USB for Input Modulation on Server and Client.
WIN10 CLIENT wfview-20221012234341.log (40.6 KB)
Pi3 SERVER wfview-20221013000049.log (13.0 KB)

Hi Stu.

Looking at your server log, you have not configured the audio devices for the server:

2022-10-13 00:00:50.014 INF gui: Got Server Audio Input: “default”

2022-10-13 00:00:50.015 INF gui: Got Server Audio Output: “default”

Within the server settings tab, you need to select your USB Audio codec devices for input and output audio. The audio devices selected within the main radio tab are NOT USED by the server.

Everything looks fine on the client

73 Phil M0VSE


Hi Phil
wfview-20221013092256.log (15.2 KB)
, many thanks for the reply. Ive tried so many times to get it to work on the USB Burrbrown settings …using QT audio. ive just learnt here that disconnecting the server , and changing the settings , reconnecting often causes noaudio at all on the client unless i save the settings on server app, close and reboot the app.This might be a Pi3 thing. For a while i lost all audio all together . Ive tried RT audio and hw:USBAudioCodec 0, for both fields and it stops working. But then i found that if I save the setting , reboot the Pi3 then i get audio at the client again. But - still no Mic Mod. I see in posts that we have Burrbrown chipset references … well I put the server into QT mode and selected the Input Burrbrown and Output Burrbrown … with sadly the same results after a save and reboot of the server.
Attached is a newlog with the QT and Burr Brown settings.

Have you tried port audio on the client.
On my server- Raspberry Pi 3b+ - I have Also Burr Brown for input and output. Audio source is QtAudio.
On the client(s), both Windows 10 Pro, I have local speakers chosen an internal microphone chosen. Audio source is port audio.

Just my experience today, getting clients to work.


Thanks Michael, i’ll try that and let you know . I think ive exhausted that setup many times. Infact, it seems to be what i already have here … i have found my Win 10 pro client the only way to get audio at all is PORT Audio.

These are the same Audio PC inputs I use for ARCP on my Kenwood 890 remote on this same laptop as a client which works fine, so laptop hardware is ok for assurances on that aspect . So i know my audio is getting Into the laptop from the Headset - and naturally i have checked the levels and ihave plenty of mic volume in PCsettings for Micinput checks . What is a bit bizzar is how many audio options there are to choose from & i dont know why that is. My thinking is this issue is back in the Server ( pi3 ) as i am having trouble trying to determine how the Pi3 even uses a Mic input . The Pi3 shows USB CODEC for the Mic on its desktop. Ive tried the USB chown dev/USB* . Full image replacement on the Pi3 isin order i think , will do that and see what happens. What would be great is if there was a Audio Meter on the wfview VIEW area …so i can see that the actual Mic Input is being accepted for processing to IP.

You can enable the audio meter as a secondary meter under settings on the User Interface page. It will only show on the client but can be super useful for troubleshooting.

Case Closed now i think … I rebuilt the full Pi3 image from scratch . Rebooted , updated the Pi . rebooted .Downloaded Wfview , Full install - NO radio attached to usb , just Keyboard & Mouse only
Rebooted Pi after install . Plugged in IC7300 USB ,waited a few minutes .
Started Wfview - disconnected the attempted connection . Set Serial as per standard
Selected QT audio and found Burr Brown TI-USB Codec -00 …this definition looked a little different this time around . Setup Server User & Pass . Connected to 7300
CLIENT on Win10 , setup as PORT AUDIO and selected Headphones & Mic accordingly while headset was plugged in . Saved Settings. Close and restart client . RXlatentcy went green …audio sounds different …& TADAA !!! -We have Mic modulation from the client to the server - to the IC7300. Bingo :slight_smile:
Thank you all for your patience. This build once setup remotely will allow many club members to enjoy remote control of ZL2GT IC7300 and digi modes too . Running via WAN is already sorted as i had control working within 5 mins out of the box. Sincere thanks to all that have assisted here.
Kind Regards Stu ZL2XC

1 Like