Icom IC-7300 with WFView 1.50 - No audio on server or client

I am using an Icom IC-7300 with WFView 1.50, I cannot get any audio on the server (win10) or client (win11) PC. I have tried various settings and even reinstalled the Icom driver. All of the controls and waterfall function as they should.

Please help.

Thank you,

Hi Ed,

What audio devices have you selected under Radio Server? How about the audio devices on the client side under Radio Access?

Can you please share with us your logs from both the client and the server? It seems likely to me that either your server has the wrong audio device selected, or the client has the wrong audio device selected (or both). The log file will tell us what the program is doing.


Just press “Log” and then you can press “Send to termbin” or you can attach the log as a file. Please do on both the server and client side, after a connection is made between them.


de W6EL

I have the same issue. I have RS-BA1 on this machine and it connects and gives good audio to the same audio connections, but wfview is dead quiet. I have it set up to go to a USB headset, which in fact is the “default” for that machine (my amateur radio server). All other controls are fine, but audio is the issue.

Hi Don.

Please post logs as Elliott has asked Ed to do. Without these, there could be 101 potential causes.


Hi Elliot,

Thanks for the reply. I have tried all 3 audio options and multiple selections under each. I’m not really sure which to pick. Here is the link to the uploaded log file. https://termbin.com/q19d

Thanks again,

Here is another log after messing with some of the audio settings. I disabled server and am trying to get it working locally first. https://termbin.com/4n62q

Thanks again,

I did get it working on the client using portaudio, however I still cannot get any audio on the server computer.

Thanks again,

Hi Ed,

On the server, wfview merely makes the audio available on the network. If you’ve got audio on your client side, then the server side audio is working! Which is good!


de W6EL

Hi Ed

That’s correct, generally the server computer is next to the radio so it doesn’t really make sense for it to have radio audio. The audio is passed straight through to the server.

The audio input/output boxes in the radio settings are for LAN connected radios only and are not used where the radio is connected over usb.


Ok, very good.

Thank you guys!


I have the same problem - no audio with 1.5 on client. I had it working previously before upgrade.
Log says it is looking for sound device-install libqt5multimedia-plugins. How do I do that?

Thanks - N2OII


The warning about libqt5multimedia-plugins is only for linux, and even then not always correct.

Can you share your log?

de W6EL

Resent log: https://termbin.com/mjs36

And what’s the link of where you uploaded the log?

(you edited your original post; thanks for the clarification)

Have you been able to look at the log and see what my problem is?


Hi rfguy,

The issue is “no audio devices found”.

Can you try the latest weekly public build and see if it fixes the issue? Just save the exe file in the same folder as your existing wfview.exe file, and be sure to double-click the new version instead of the old one. You can keep the old version around, it does no harm.

de W6EL


It was rather obscure to figure out but the suggestions about PortAudio helped break through.

I had to put a headset on my server for the audio location (or so I think), and then the signal was routeable using PortAudio.

On the Server a different story in that I had 3 audio outputs on QTaudio, but 10 with PortAudio. Trying them until I didn’t get a distorted output on AM radio was the key. Which one did I end up with? No clue, but I know the speakers and microphone should be better now.

Now to see if I can get the right mic setup. My confusion arose from the difficult way to determine the audio output devices on the server needed, and then the client.

Sadly, the audio is nearly unusable on AM radio with a massive amount of noise at high AF. I cut it back and the noise level dropped while still getting good output audio.

Not sure if I’ve got it right yet, but this thread did help me get a lot further than before. THANKS FOR YOUR HELP! :slight_smile:

1 Like

I have a similar issue. IC7300 with Raspberry Pi Server. Can get things to work properly with the desktop sitting next to the Server. Desktop in a home built AMD processor. I cannot get it to work with a client running on a Lenovo Windows 10 Pro Laptop. Client log sent: https://termbin.com/p3gy
Log states can’t find audio device - Using Alsa_Output usb-Burr-Brown and Alsa_input usb-Burr-Brown on the Serer. Server log - https://terbin.com/7gou
Clarification - No Audio to the Laptop, but have control of the functions of the radio. Server connected to network with cable and Laptop connected to network through wireless.
Version 1.5 on Server and Client(s). Running Client 1.1 on the Laptop I was able to connect to the Server and had audio and radio control.

disconnect and use one of the other audio modes, reconnect?

There are three : QT, Port and RT as audio stacks. . Also note that you should select the right audio output (and input) device.